
Kartografische Funktionen

in Form von Plugin’s für Adobe Illustrator Version CS bis CS5

Die heute verfügbare, kartografisch ausgerichtete Software ist für relativ wenige Benutzer geschrieben und
mangelt deswegen oft an Aktualität, Stabilität, Flexibilität und ist in der Regel teuer.  Der vielfach eingesetzten 
GIS- Software fehlt es zum Teil immer noch an geeigneten kartografischen Werkzeugen. Bei beiden ist eine 
Integration von eigener oder Drittsoftware schwierig oder gar unmöglich. Autorensoftware zu entwickeln ist 
aufwendig an Geld und Zeit.
Desktop Publishing Systeme (DTP) haben zwar ebenfalls keine kartografisch ausgerichtete Werkzeuge,
verfügen aber über eine ausgezeichnetete grafische Umgebung und über mehr oder wenig aktuelle und
umfangreiche Integrationsmöglichkeiten von eigener oder Drittsoftware.
Die DTP- Produzenten stellen Software Developement Kits (SDK) bereit, um auf der Basis von C/C++, Basic
oder Scriptsprachen Plugin’s zu erstellen und in die DTP zu integrieren.
Nachteilig ist die Abhängigkeit von den DTP- Herstellern bezüglich der Konstanz und Aktualität.

Wir haben Plugin’s für folgende Anwendungsgebiete entwickelt:
- Datenharmonisierung, das Anpassen Datenbestände verschiedener Quellen mit unterschiedlicher Qualität,
- Generalisieren,
- Symbolisieren,
- thematische Darstellungen, wie Diagramme, choropleth maps, irregular pattern.
Die Funkionalität wird entsprechend den Notwendigkeiten laufend angepasst und erweitert.

Die aktuell verfügbaren und und hier aufgeführten Funktionen lassen sich in vier Kategorien einteilen:
Informieren, Auswählen, Verändern und Generieren.

Die Plugins LineToBezier, BezierToLine, ClosePath, PointElimination und Rectify enthalten zusätzlich noch 
eine Effect-Funktion.



Aktuelle Funktionen

Name des Plugin’s Aufruf:      Kategorie: Funktion:           Seite:

Selected(.aip)  Window > KAR Dialogs > Show Inform Dialog  Informieren Informiert über alle selektierten Objekte       1
    

Messages   > Show Message Dialog     Die zuletzt getätigten Plugin’s werden mit ihren wichtigsten     2
           Ergebnissen angezeigt.

selectInsideArea  Object > Filter > DataHarmonisation > Select Inside Areas Auswählen Innerhalb von Flächen befindliche Objekte werden selektiert    3
    
selectBySameGeometry  > Show Inform Dialog     Identische Path- Objekte resp. Gruppen werden selektiert.     4 
           

keepSelectedByGeometry   > keepSelectedByGeometry                     Alle nicht zutreffende Objekte bleiben selektiert      5
     

keepSelektedByName  > keep Select by Name     Alle Objekte welche den vorgegebenen Text in ihrem Namen haben   6
           verbleiben selektiert.

snapPoints   > Snap Points    Verändern Punkte verschiedener Path- Objekte werden ausgemittelt oder    7 
           übernommen, sofern ihre Abstände einen Schwellwert unterschreiten.
 

closePath    > Close Path Objects     Einzelne offene Path- Objekte werden geschlossen     8

AreaBuilder   > AreaBuilder      Aus offenen Path- Objekten werden geschlossene      9
           Path- Objekte (Flächen) gebildet. 

Rectify    > Rectify closed path     Die Winkel von Flächen werden, sofern sie von 90 Grad wenig  10 
           abweichen (Schwellwert), auf 90 Grad gesetzt.

PointElimination   > Point Elimination (excl. Nodes)    Punkte von Path- Objekten werden richtungsunabhängig   11 
           gelöscht (Schwellwerte).

connectPath   > Connect Paths      Offene Path- Objekte werden vereinigt, wenn Endpunkte identisch  12 
           sind.

Adaption    > Adaption to one path     Path- Objekte werden auf ein Path- Objekt einer andern Ebene  13 
           angepasst.

setNodes    > Set Nodes by Disconnect Path- Objects   Pathobjekte werden an Verzweigungen aufgetrennt   14 

LineToBezier   > Line To Bezier      Lineare Polygonzüge werden in Bezier- Kurven umgerechnet.  15 
           Bezier- Kurven werden neu bestimmt.

AreaNodes   > Restore Area Nodes     Durch  Line To Bezier  erzeugte Inkonsistenzen werden bereinigt.  16 
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Seite 1 
Selected.aip
Aufruf:   
Window > KAR Dialogs > Show Inform Dialog

Anwendung in Beispiel 1 Seite1 und B2 S1

Funktion:
Nach Update Info wird die Anzahl aller 
selektierten Objekte angezeigt. Textobjekte
werden nicht mitdazugezählt.
Jeder Layer gilt als eine übergeordnete
Gruppe. Ein Dokument mit einem Pathobjekt
besitzt mindestens zwei Objekte, nämlich 
eine Gruppe und ein Path, weil jedes Objekt 
einem Layer angehören muss.
Unter Bezier werden alle Pathobjekte
zugeordnet, welche mindestens bei einem
Segment vom Ankerpunkt abweichende
Tangentenpunkte aufweisen. Aussschliess-
lich gradlinige Verbindungen werden unter
straight aufgeführt.

Vorgesehene Erweiterungen:
In späteren Illustrator- Versionen werden auch
selektierte Texte mitaufgeführt.



Seite 2 

 

Messages.aip
Aufruf:  Window  >  KAR Dialogs > Show Message Dialog

Anwendung in Beispiel 1 Seite 2, B4 S1, 
B7 S1 und B2 S1

Funktion:
Ausführliche Meldungen und Dialoge 
unmittelbar nach der Anwendung eines
Filter- Plugins, sind nur schwierig und 
umständlich durchzuführen.
Nur zwingend notwendige Fehlermeldungen, 
z. B. nach einem Programmabbruch werden 
durch Filter- Plugins selbst ausgeführt.
Deshalb wurde eigens dafür dieses Plugin
bereitgestellt. 
Nach jeder Ausführung eines Filter- Plugins werden die nennenswerten Ergebnisse oder
Vorkommnisse gespeichert. Mit Update Messages können die Ergebnisse der letzten
und mit  <<<  die der früheren Ausführungen eingesehen werden.
Messages und Inform werden (leider) auch als Plugin- Ausführungen mitgezählt.
Wird in das Feld unter  <<<   eine 0 eingegeben und anschliessend ein Update Messages 
getätigt, werden alle gespeicherten Messages gelöscht.
Plugins ausgeführt via Place, Exports, Window und Icons können keine Informationen
nach Messages.aip transferieren. Im Beispiel 7 Seite 1 wird die (umständliche) Hand-
habung einer Fehlermeldung bei einem Import via Place demonstriert.



komplett: mit dem Zentrum:

Auswahl-
fläche
A hl

mindestens mit
einem Punkt:
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SelectInsideArea.aip

Aufruf:  Object  >  Filter  >  Data Harmonization > Select Inside Areas

Anwendung in Beispiel 6 Seite 6

Funktion:
 

Plugin Messages:

Vorgesehene Erweiterungen:
  

Zusammengesetzte Pfade



Seite 4
SelectBySameGeometry.aip

Aufruf:  Object  >  Filter  >  Data Harmonization > Select by same Geometry

Anwendung in Beispiel6 Seite7 und B8 S1

Funktion:
Alle Path- Objekte, welche innerhalb einer 
Toleranz identisch sind, werden selektiert.
Wenn die gefundenen Path- Objekte jeweils
Teil einer Gruppe sind, können auch die
kompletten Gruppen selektiert werden.
Rotierte Path- Objekte werden nur innerhalb
der Prüfgenauigkeit erfasst.
 

 

Plugin Messages:

Fehlermeldung:

Vorgesehene Erweiterungen:
Rotation der Objekte mit einbeziehen

Select same paths                        Select complete groups

vorselektiertes Path
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keepSelectedByGeometrie.aip 

Aufruf:  Object  >  Filter  >  Data Harmonization > Keep Path selected by Geometry

Anwendung in Beispiel1 Seite1  

Funktion:
Deselektiert alle Objekte, bei denen keine der 
ausgewählten Kriterien zutrifft.
Bei lagegleichen Kopien wird eine Kopie ent-
selektiert, sofern alle identischen Objekte auf 
einer Ebene liegen.
Sind sie auf verschiedene Ebenen verteilt, so
muss der Anwender entscheiden, was ge-
löscht werden soll.
Um eine Kontrolle über die Ursachen für
die selektiert verbleibenden Objekte zu
behalten, sollte für jede “Geometrische 
Auswahl” eine getrennte Ausführung dieser
Funktion vorgenommen werden.
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keepByName.aip

Aufruf:  Object  >  Filter  >  Data Harmonization > keep Select By Name

Anwendung in Beispiel 6 Seite 6  

Funktion:
Alle Objekte welche in ihrem Namen das
vorgegebene Textstück (ing) aufweisen, 
verbleiben nach diesem Dialog selektiert
z.B.: 

Plugin Messages:



geschützt
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Snap Distanz

snapPoints.aip 

Aufruf:  Object  >  Filter  >  Data Harmonization > Snap Points

Anwendung in Beispiel 1 Seite 3 , B3 S3
und B7 S6

Funktion:
Bei Unterschreitung der eingegebenen
Distanz werden entweder die Punkte zweier 
oder mehrerer Paths ausgemittelt  oder die 
Punkte der ungeschützten Layer  werden 
denen des geschützten Layers angeglichen.
Die Punkte eines Paths untereinander
beeinflussen sich nicht. Alle selektierten 
Punkte werden in einem Aufruf berücksichtigt.

Beispiele:

Zur Kontrolle von visuell nicht mehr erkenn-
baren Korrekturen können Markierungen 
angebracht werden. Diese sind in einem 
seperaten Layer (MARKIERUNG SnapPoint)
untergebracht. Die Markierungssymbole bzw. 
-Layer sollten gelegentlich gelöscht werden.

Plugin Messages: Warnung:



closePath.aip 

Aufruf:  Object  >  Filter  >  Data Harmonization > Close Path Objects

Anwendung in Beispiel 7 Seite 7

Funktion: 
Einzelne offene Pathobjekte werden geschlossen,
entweder durch Ergänzen oder durch Ausmitteln,
sofern die vorgegebene Snapweite unterschritten
wird. Die Snapweite ist nur beim Ausmitteln 
wirksam. Beim Ergänzen wird jeweils der Start-
punkt mit dem Endpunkt unabhängig ihrer 
Distanz zueinander durch ein zusätzliches 
Segment verbunden.

Beispiele:    Ergänzen:         Ausmitteln:

Hinweise: Das Plugin Improve Beziers and Lines bietet ebenfalls die Möglichkeit zum 
  Schliessen von Pathobjekten.
  Mit AreaBuilder können aus mehreren offenen Pathobjekten Flächen 
  gebildet werden. 

Plugin Messages:

Seite 8

 

Snapweite:
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Offene einzelne Path sollten via
Close Path Objects oder 
Improve Beziers and Lines
geschlossen werden.

AreaBuilder.aip 

Aufruf:  Object  >  Filter  >  Data Harmonization > AreaBuilder

Anwendung in Beispiel 1 Seite 4  

Funktion:
Aus mehreren offenen Path- Objekte werden 
geschlossene Path- Objekten erzeugt, sofern
die Endpunkte der einzelnen Path- Objekte
lagegleich sind. Gegebenenfalls sollte eine
Bereinigung mit Snap Points voraus durch-
geführt werden.
Zur Begrenzung der Laufzeiten sollte die 
Anzahl der beteiligten Path- Objekte für
die komplexeste Fläche angegeben werden. Flächen aus sehr vielen Paths (>20) sollten
separat erzeugt werden. Es es ist Empfehlenswert die maximale Laufzeit auf 10 Sekunden
zu belassen. Sind 10 Sekunden zu kurz (keine Flächenbildung), kann via Messages
die erforderliche Laufzeit abgefragt werden. Die Laufzeiten werden vom Plugin höchst 
ungenau geschätzt (Faktor 10 nach unten wie nach oben).   

Erfolglose Beispiele:

Plugin Messages:

 

Zuerst mit Snap Points
Enden lagegleich setzen.

Die einzelnen Path- Objekte soll-
ten identische graphische Atribute
haben (Farbe,Dicke,etc.) und 
zur gleichen Ebene gehören.



Seite 10
Rectify.aip

Aufruf: Object  >  Filter  >  Data Harmonization > Rectify closed Path

Anwendung in Beispiel 9 Seite 3 und B4 S1

Funktion:
Geschlossene Path- Objekte werden nach 
einer ausgemittelten Vorzugsrichtung 
rektifiziert (rot).
In diesem Beispiel werden Segmente
mit Abweichungen > 15 Grad von der 
Vorzugsrichtung nicht rektifiziert (        ).  

Vorgesehene Erweiterungen:  
Mehrere (max. 3) Vorzugsrichtungen.

Die Funktionen Orientieren (Ausrichten)
und Positionieren auf eine Referenzgerade 
werden ausführlich im Anwendungsbeispiel 
B9 S3 erläutert.

Plugin Messages:

Fehlermeldungen:



geschützte Knoten
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PointElimination.aip 

Aufruf:  Object  >  Filter  >  Data Harmonization > Point Elimination (excl. Nodes)

Anwendung in Beispiel 2 Seite 1 und B3 S1 

Funktion:
Gegenüber den meisten punktreduzierenden
Methoden (Illustrator, Freehand, etc.) arbeitet 
diese Funktion richtungsunabhängig. Für die 
Bearbeitung von angrenzenden Flächen
ist dies eine unbedingte Notwendigkeit! 
Zudem werden vorhandene Knoten geschützt
d. h. lagegleiche Punkte verschiedener Path-
Objekte bleiben erhalten auch wenn sie
gemäss den Parameter gelöscht werden 
müssten.

Explizite Knoten:

Implizite Knoten:

Plugin Messages:



P1
P2

P3
nach Connect Path   Close Path Objects

Die Frage: “Sollen die Path getrennt 
bleiben?” hat keine Bedeutung, sofern 
P1, P2 und P3 die gleichen graphischen 
Attribute haben. Der Knoten zwischen 
den drei Path - Objekten bleibt erhalten.
Falls P2 und P3 sich von P1 unter-
   scheiden, werden bei 
   einem      P2 und 
   P3 zusammengefasst.
                       Bei einem       würde der 
   Knoten erhalten bleiben.

Seite 12
connectPath.aip 

Aufruf:  Object  >  Filter  >  Data Harmonization > Connect Paths

Anwendung in Beispiel 1 Seite 2 und B3 S3 

Funktion:
Offene Path- Objekte werden zu einem Path
zusammengefasst, sofern sie identische
grafische Attribute besitzen und sich in der 
gleichen Ebene befinden. Ausserdem müssen
die zusammengehörigen Endpunkte lagegleich
sein (Snap Points).

Mit dieser Funktion können keine geschlossenen
Path’s erzeugt werden (AreaBuilder).
Sollte ein geschlossenes Path- Objekt mit einem
bestimmten Punkt Starten resp. Enden, kann 
dies mit den folgenden Schritten erreicht werden:

 

Plugin Messages:

P1

P3

P2

P1P1

P2

P2

P3

P4

      

     



6 Punkte 48 Punkte

zuwenig Punkte

zweimal
Objekt > Path > Add Anchor Points

Aufruf:  Object  >  Filter  >  Data Harmonization > Adaption to one Path
Anwendung in Beispiel 1 Seite 2 und B3 S2

Funktion:
Mehrere Pathobjekte, geschlossene oder offene,
werden an ein Referenz- Objekt angepasst. 
Dieses Path muss sich in einer separaten 
Ebene, der Referenzebene, befinden.
Adaption wurde für geradlinige und Bezier-
Kurven entwickelt. Bei Bezierkurven müssen 
an Verzweigungen eventuell die Tangenten 
korregiert werden. 
Falls die Dichte der anzupassenden Segmente 
sich von der Dichte der Referenzsegmenten 
stark unterscheidet, müssen zusätzliche Anker-
punkte eingefügt werden, entweder einzeln 
(Add Anchor Point Tool) oder auf alle Segmente 
der selektierten Path- Objekte via  
Object > Path > Add Anchor Points.

Plugin Messages:

 
 

Adaption.aip
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setNodes.aip 

Aufruf:  Object  >  Filter  >  Data Harmonization > Set Nodes By Disconnect Path Objects
Anwendung in Beispiel 1 Seite 4 und B1 S5

Funktion:
Ueberall dort wo Path- Objekte lagegleiche 
Punkte aufweisen, werden sie aufgetrennt.
An diesen Positionen entstehen (fiktive)
Knoten.

 

Elemente in geschützten Layers werden 
benützt, jedoch nicht verändert.

Als Spezialfall können mit dieser Funktion
Path- Objekte an allen Punkten aufgetrennt 
werden.

Plugin Messages  
 

 

==>

- Copy
- Paste in Front (Back)
- Beide Path- Objekte selektieren
- Set Nodes By Disconnect Path Objects
- KeepSelectedByGeometry
   (lagegleiche Paths)
- Clear (Delete)

P1

P3

P23

P22
P21

P13

P12

P11P3

P2

==>
P1

P3

P2

P13

P12

P11P3

P2

P1

P3P2

P1
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LineToBezier.aip 

Aufruf:  Object  >  Filter  >  Data Harmonization > Line To Bezier

Anwendung in 
Beispiel 2 Seite 2, B3 S1, B3 S3 und B4 S1  

Funktion:
Path- Objekte, Geradenverbindungen oder
Bezierkurven, werden in Bezierkurven mit
symetrischen Tangenten umgerechnet.
Bei zu grossen Winkeländerungen können 
die Kurven unterbrochen, d.h. unstetig 
gehalten werden.

Tangentenausprägung   = 0.0:

                                       = 0.5:

                                       = 1.0:

Glättung    = 0.0  = 1.0:

                 = 0.5  = 1.0:

                 = 1.0  = 1.0:

Kontinuität = nein                              ==>

                    = ja                                ==>

Verzweigungen = nein                      ==>

                  Zusammen mit einer geeigneten 
                          = ja                          ==>                         Snapdistanz (z.B. 0.5mm)
                                                                                         werden Verzweigungen gebildet.

Unstetigkeit bei Winkeländerung ( > 40 Grad)
 
= nein                                  ==>

= ja                                      ==>    

Plugin Messages:
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AreaNodes.aip 

Aufruf:  Object  >  Filter  >  Data Harmonization > Restore Area Nodes

Anwendung in Beispiel 2 Seite 2

Funktion:
Line To Bezier interpoliert Flächen unabhängig
der anderen Flächen. Die dabei entstehenden
Überschneidungen werden durch  Restore 
Area Nodes  korrigiert. Die Verarbeitung erfolgt 
ohne Parameter, also ohne Dialog.
 

Plugin Messages:

Mögliche Erweiterungen:  
weitere knotenbezogen Funktionen 

 
 
 

 

==>
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BezierToLine.aip 

Aufruf:  Object  >  Filter  >  Data Harmonization > Bezier To Line

Anwendung in Beispiel 2 Seite 2

Funktion:
Bezierkurven werden in lineare Segmente 
umgerechnet. Eine maximale Abweichung
von der Kurve bestimmt die Anzahl der
zusätzlichen Segmente abhängig von der
Krümmung. Mit dem dem zweiten Para-
meter wird bei stark gekrümmten Kurven-
segmenten auf Kosten der Genauigkeit die 
Anzahl der linearen Segmente begrenzt.

Plugin Messages:

 
 
 

 

==>



 alfa > 30 Grad

alfa <= 30 
lineare
Segmente

a:

c:

b:

 Interpolation = 1.0

 Interpolation = 0.5
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ImproveBeziers.aip 

Aufruf:  Object  >  Filter  >  Data Harmonization > Improve Bezier and Lines

Anwendung: in keinem Beispiel 

Funktion:
Im Gegensatz zu Line To Bezier, welches immer 
komplette Path- Objekte verarbeitet, berücksichtigt 
dieses Plugin via Lasso oder rechtem Selektpfeil  
selektierte Punkte.

Schliessen offener Polygone funktioniert wie
Close Path Objects mit Parameter Ausmitteln,
Die Snapweite dafür kann angegeben werden.
Zusammenfassen naher Punkte fasst alle innerhalb 
der vorgegebenen Distanz liegende Punkte zu einem 
Punkt zusammen.
a:  Alle geradlinigen Segmente erhalten 
     Bezier- Tangenten. Kurven mit einer 
     Unstetigkeit > Alfa werden neu angepasst.
b:  Kurven mit Unstetigkeiten < Alfa werden 
     angepasst. Geradlinige Segmente bleiben 
     unverändert.
c:  Über alle selektierten Punkte wird neu interpoliert,
     siehe Line To Bezier. Alfa hat in dieser Teilfunktion
     keine Bedeutung.
d:  Es werden ausser Schliessen und Zusammenfassen
     (falls     ) keine Veränderungen vorgenommen.

Warnung:
Nach undo verbleiben die vom Lasso eingekreisten 
Path-Objekte komplett selektiert.      

Plugin Messages:

Lasso 

 

90 90 90909
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adjustMaps_Dialog.aip 
Aufruf:  Window  >  KAR Dialogs > Show AdjustMaps_Dialog

Anwendung in Beispiel 5 Seite 1 und B5 S2

Funktion:
Es wird davon ausgegangen, dass es bei 
der Anpassung zweier Datenbestände aus 
unterschiedlichen Quellen und eventuell 
verschiedener Massstäbe, Objekte gibt, 
welche in beiden Datensätzen vorkommen 
und referenziert werden können.
In den meisten Fällen sind dies Flussein-
mündungen in grössere Flüsse oder Seen. 
Selbstverständlich sollen mit dieser Trans-
formation nur die grösseren Abweichungen 
korrigiert werden.
Die massstabsbedingte Generalisierung muss 
im  Wesentlichen erhalten bleiben.

Plugin Messages
entsprechen denen des Plugins



Aufrufe: Window > Tools >

Anwendung in Beispiel 4 Seite 1 

Funktion:
Der Radius des Wirkungsbereiches wird mit dem rechten Icon entweder am Lineal, an der
Graphik oder irgendwo im Dokument mit einer Mausbewegung im gedrückten Zustand 
definiert. Er kann mit Message Dialog abgefragt werden. Diese Definition kann jederzeit 
vorgenommen werden.
Mit dem linken Icon werden die selektierten Punkte bewegt, sofern sie im Wirkungs-
bereich liegen. Die Verschiebung nimmt linear vom Ansatzpunkt ab.

Plugin Messages:

Mögliche Erweiterungen:  
Neben einem linearen Verlauf der radialen Abnahme 
könnte eine andere Formel hinterlegt werden,
z.B. nach Gauss, logarithmisch,...
 

Anwendungsbeispiel:

Wirkungsbereich:                  SpecialMove:
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specialMove.aip 

71.7
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Thm_Diagrams.aip 

Aufruf:  Object  >  Filter  >  Thematic Maps > Diagrams

Anwendung in Beispiel 7 Seite 1-7 

Funktion:
Setzt statistische Daten in Diagramme und
Choroplethen um.
Über  File ==> Place ==> Tab separated Excel text
file (*THM)  wird der statistische Datensatz eingelesen.
Im Hauptdialog werden die generellen Parameter
definiert und der grafische Darstellungstyp 
(Diagramm, Symbol oder Einfärbung) ausgewählt.

In einem Subdialog wird die gewählte grafische
Darstellung spezifiziert. Einige der diagramm-
spezifische Subdialoge werden im Anwendungs-
beispiel 7 näher beschrieben.
 . 

 

Einige Diagrammvarianten:

Plugin Messages:  
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triangleMakeClasses.aip 

Aufruf:  Object  >  Filter  >  Thematic Maps > Create Triangle

Anwendung in Beispiel 7 Seite 6

Funktion:
Erzeugt ein gleichseitiges Dreieck für eine 
spätere Klassenbildung von jeweils drei 
ortsbezogenen, absoluten Werten. Die etwas
aufwendige Einteilung in Klassen wird in dem
Subdialog Klassenbildung im Dreieck im
Anwendungsbeispiel 7 Seite 6 vorgestellt.
        

        Plugin Messages:  
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placeSymbols.aip

Aufruf:  Object  >  Filter  >  Thematic Maps > Place Symbols

Anwendung in Beispiel 6 Seite 7 und B8 S1

Funktion:
Eine Gruppe (Symbol) wird auf selektierte 
Path- Objekte oder deren Ankerpunkte
platziert.

Plazierung der Symbole auf
die Zentren:                                                          auf die Startpunkte:                       oder auf alle Punkte der Path- Objekte:             

Default Referenzsymbol:                      Plugin Messages:

Benützer definierte Referenrsymbole:

 

 
 
 

 

=
=

>
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IrregularPattern.aip

Aufruf:  Object  >  Filter  >  Thematic Maps > Irregular Pattern

Anwendung in Beispiel 6 Seite1 - 5 

Funktion: 
Die meisten Strukturraster enthalten oft wieder-
kehrende Muster (Tapeten) und angeschnittene
Symbole. Individuelle Lösungen sind in der 
Regel nicht möglich.
Mit Filter > Thematic Maps > Irregular Pattern 
können sehr spezifische Strukturraster erzeugt 
werden, wie Wälder, Sümpfe, Geröllflächen, 
Kiesgruben, Böschungen, etc.
Die Funktion Strukturraster wird ausführlich
in dem Anwendungsbeispiel 6 und in
http://www.ika.ethz.ch/plugins/en/irregular_pattern_plug_in.pdf
beschrieben.

 

Plugin Messages:
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PointCluster.aip

Aufruf:  Object  >  Filter  >  Thematic Maps > Point Cluster

Anwendung in Beispiele 9 Seite1 und 2

Funktion:

Anwendungsbeispiele:

Vorgesehene Erweiterungen: 
Automatische Generierung von Objekten des 
Typs:  Zusammengesetzte Pfade (compounds)  
 

 
 
 

Plugin Messages:

Aus Punktwolken oder aus Flächen werden
Cluster- Flächen gebildet.



Aufruf:  Object  >  Filter  >  Thematic Maps > Adjust Symbols

Anwendung in Beispiel 10 Seite 1

Funktion: 
Ausgehend von geschlossenen Path- 
Objekten, welche innerhalb einer Snapweite
von offenen Path- Objekten liegen, werden 
vordefinierte Symbole (Gruppen)
 (THM_SYMBOL_REFERENCES),
tangential auf die offenen Path- Objekte
ausgerichtet und platziert.

Vorgesehene Erweiterungen: 
Angleichen an Objekte des Typs:  
Zusammengesetzte Pfade (compounds)  
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AdjustSymbols.aip

Referenzsymbole:

Plugin Messages:

Default
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generalizeBuildings.aip

Aufruf:  Object  >  Filter  >  Data Harmonization > Generalize Buildings

Anwendung in Beispiel 9 Seite 4

Funktion:
Vorwiegend rechtwinklige Flächen werden
auf ihre Vorzugsrichtung (Modulo 90 Grad) 
geprüft und je nach der gewählten 
“Generalisierung” in Form von einfachen 
Rechtecken, Eckgebäuden oder Reihen 
von Rechtecken in die gewünschte Ebene 
abgelegt.Die Reihen werden entweder 1:1 
geordnet oder auf wenige Flächen redu-
ziert dargestellt. 
Mit einem Anpassungsfaktor können die 
resultierenden Flächen verstärkt oder
abgeschwächt werden. 

Anwendungsbeispiel:

Vorgesehene Erweiterungen: 
- vorgegebene Richtungen
- z.B. von Strassen definierten Blöcke
- angepasste umhüllende Flächen 
 

 
 
 

zusammengefasste 
Flächen (Gebäude)

Plugin Messages:



Schnittpunkte

intersectByLinearPath.aip
Seite 28

Plugin Messages:

Aufruf:  Filter >  Data Harmonization > Intersection by linear Path Objects 

Anwendung in Beispiel 11 Seite 2

Funktion:
Mit linearen Path- Objekten, geschlossene 
(Schnittflächen) wie auch offene (Schnitt-
kanten), können beliebige Path- Objekte, 
incl. Bezierkurven, geschnitten werden.
Die bearbeiteten Objekte werden entweder
aufgetrennt oder durch die Schnittpunkte 
erweitert. 
Komplexe Geometrien können minutenlange 
Ausführungszeiten verursachen. Obwohl
die Mitteilung  no response  auftreten kann,
wird die Operation korrekt ausgeführt.

Bezier- Segmente
schneiden linear
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Fels_Parameter.aip

Aufruf:  Window > KAR Dialogs > Felsbänder Dialog
Anwendung demnächst in B12 S1

Funktion: 

 
 
 

Vorgesehene Erweiterungen: 
- Keine

Ausgegangen wird von einem oder mehreren
offenen Path-Objekten. Die Objekte müssen 
eine gerade Anzahl von Stützpunkte aufweisen.
Die erste Hälfte eines solchen Path definiert
die Lage der Oberkante, die zweite Hälfte die 
der Unterkante eines Felsbandes.
Die Art der Beleuchtung und der Parameter
Felsobjekt legen die Grundwerte für die 
verschiedenen Strichstärken fest.
Der Anwender kann die vorgegebenen Strich-
stärken noch abändern und zusätzlich 
Skalieren und eine Maske für den Hintergrund 
generieren.

konkav             linear                konvex
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SmoothLineWidth.aip

Aufruf:  Object > Filter > Data Harmonization > Smooth Line Width

Funktion: 

 
 
 

Orginal:

Ohne Unterteilung
der Segmente:

Mit Unterteilungen
der Segmente:

Plugin Messages:

Flüsse werden in der Regel aus mehren
Path-Objekten gebildet, von der Quelle
an mit zunehmender Breite. Die meist
sprunghaften Änderungen sind oft störend. 
Diese Funktion gleicht die Breite von
Segment zu Segment oder von Unterteilung
zu Unterteilung aus.



Aufruf:  Object > Filter > Thematic Maps > Regular Line Pattern

Anwendung in B10 S1

Funktion: 
Vordefinierte  Gruppen (Symbole),  werden 
auf Pfade regelmässig tangential angeordnet. 
Sowohl offene wie auch geschlossene Pfade, 
mit linearen und Bezier -Segmenten werden 
berücksichtigt.

Plugin Messages:
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RegularLinePattern.aip



areaCalculation.aip

Aufruf:  Object > Filter >  Data Harmonization > Area Calculation (incl. Bezier)

Anwendung in Beispiel 8 Seite 3

Funktion:
Die Flächen geschlossener Path und einfach 
strukturierter Compound Path werden in
Millimeter berechnet und als Text in der 
generierten Ebene calculatet areas 
festgehalten. 
Komplexere Compounds, zum Beispiel
zusammgesetzt aus Exklaven, Enklaven und
Ueberschneidungen von Flächen,
müssen sinnvollerweise aufgelöst und als 
einfache Path- Objekte berechnet werden.  
 

Plugin Messages:

  
 
 

 

Einfache Paths:

Einfache struktuierte
Compounds:
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   152.6

    6.61

   10.85

   135.1

   117.7

Komplex strukuierte 
Compounds:

aufgelöst:

   139.2

    6.61

   10.85
   135.1

    6.61
   10.85

   135.1

   291.9
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