Kartografische Funktionen

in Form von Plugin’s fiir Adobe Illustrator Version CS bis CS3

Die heute verfugbare, kartografisch ausgerichtete Software ist fr relativ wenige Benutzer geschrieben und
mangelt deswegen oft an Aktualitat, Stabilitat, Flexibilitdt und ist in der Regel teuer. Der vielfach eingesetzten
GIS- Software fehlt es zum Teil immer noch an geeigneten kartografischen Werkzeugen. Bei beiden ist eine
Integration von eigener oder Drittsoftware schwierig oder gar unméglich. Autorensoftware zu entwickeln ist
aufwendig an Geld und Zeit.

Desktop Publishing Systeme (DTP) haben zwar ebenfalls keine kartografisch ausgerichtete Werkzeuge,
verfligen aber Uiber eine ausgezeichnetete grafische Umgebung und Giber mehr oder wenig aktuelle und
umfangreiche Integrationsmdglichkeiten von eigener oder Drittsoftware.

Die DTP- Produzenten stellen Software Developement Kits (SDK) bereit, um auf der Basis von C/C++, Basic
oder Scriptsprachen Plugin’s zu erstellen und in die DTP zu integrieren.

Nachteilig ist die Abhdngigkeit von den DTP- Herstellern bezlglich der Konstanz und Aktualitét.

Wir haben Plugin’s fur folgende Anwendungsgebiete entwickelt:

- Datenharmonisierung, das Anpassen Datenbestande verschiedener Quellen mit unterschiedlicher Qualitat,
- Generalisieren,

- Symbolisieren,

- thematische Darstellungen, wie Diagramme, choropleth maps, irregular pattern.

Die Funkionalitat wird entsprechend den Notwendigkeiten laufend angepasst und erweitert.

Die aktuell verfiigbaren und und hier aufgefiihrten Funktionen lassen sich in vier Kategorien einteilen:
Informieren, Auswdhlen, Verdndern und Generieren.

Die meisten Kartografischen Funktionen (Plugins) sind in den Anwendungsbeispielen ausfiihrlich beschrieben.
In dieser Uebersicht Gber die verfligbaren Plugins wird jeweils darauf hingewiesen in welchen Anwendungsbeispielen
und in welchen Seiten die Plugins eingesetzt werden und welche Meldungen zu erwarten sind.



Aktuelle Funktionen

Name des Plugin’s
Selected(.aip)

Messages

selectinsideArea

selectBySameGeometry
keepSelectedByGeometry

keepSelektedByName

snapPoints
closePath
AreaBuilder
Rectify
PointElimination
connectPath
Adaption
setNodes
LineToBezier

AreaNodes

Kategorie:

Window > KAR Dialogs > Show Inform Dialog Informieren

> Show Message Dialog
Filter > DataHarmonisation > Select Inside Areas Auswahlen

> Show Inform Dialog

> keepSelectedByGeometry

> keep Select by Name

> Snap Points Verdndern

> Close Path Objects

> AreaBuilder

> Rectify closed path

> Point Elimination (excl. Nodes)

> Connect Paths

> Adaption to one path

> Set Nodes by Disconnect Path- Objects
> Line To Bezier

> Restore Area Nodes

Funktion:
Informiert Uiber alle selektierten Objekte

Die zuletzt getatigten Plugin’s werden mit ihren wichtigsten
Ergebnissen angezeigt.

Innerhalb von Flachen befindliche Objekte werden selektiert

Identische Path- Objekte resp. Gruppen werden selektiert.
Alle nicht zutreffende Objekte bleiben selektiert

Alle Objekte welche den vorgegebenen Text in ihrem Namen haben
verbleiben selektiert.

Punkte verschiedener Path- Objekte werden ausgemittelt oder

ibernommen, sofern ihre Abstdnde einen Schwellwert unterschreiten.

Einzelne offene Path- Objekte werden geschlossen

Aus offenen Path- Objekten werden geschlossene
Path- Objekte (Flachen) gebildet.

Die Winkel von Flachen werden, sofern sie von 90 Grad wenig
abweichen (Schwellwert), auf 90 Grad gesetzt.

Punkte von Path- Objekten werden richtungsunabhangig
geldscht (Schwellwerte).

Offene Path- Objekte werden vereinigt, wenn Endpunkte identisch
sind.

Path- Objekte werden auf ein Path- Objekt einer andern Ebene
angepasst.

Pathobjekte werden an Verzweigungen aufgetrennt

Lineare Polygonziige werden in Bezier- Kurven umgerechnet.
Bezier- Kurven werden neu bestimmt.

Durch Line To Bezier erzeugte Inkonsistenzen werden bereinigt.

Seite:
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Selected.aip

Aufruf:
Window > KAR Dialogs > Show Inform Dialog

Anwendung in Beispiel 1 Seitel und B2 S1

Funktion:

Nach Update Info wird die Anzahl aller
selektierten Objekte angezeigt. Textobjekte
werden nicht mitdazugezahlt.

Jeder Layer gilt als eine Ubergeordnete
Gruppe. Ein Dokument mit einem Pathobjekt
besitzt mindestens zwei Objekte, namlich
eine Gruppe und ein Path, weil jedes Objekt
einem Layer angehéren muss.

Unter Bezier werden alle Pathobjekte
zugeordnet, welche mindestens bei einem
Segment vom Ankerpunkt abweichende
Tangentenpunkte aufweisen. Aussschliess-
lich gradlinige Verbindungen werden unter
straight aufgefuhrt.

Vorgesehene Erweiterungen:

In spateren lllustrator- Versionen werden auch

selektierte Texte mitaufgefuhrt.

Seite 1

Einpazsen: ™, Mez=zages N Selected

Update Info I

Total numnber of objects:

— Dbject types
Simple pathes:

OpEn: I &0
I—

straight: | 42

(2

clozed: 2

T

Beziar: 14

—

Cornpound ob jects:

Groups: I 12
Layers: |7
— Contents

Yarfices: |542

Faths within cormpound objects: I 0




_ Seite 2
Messages.aip

Aufruf: Window > KAR Dialogs > Show Message Dialog

Anwendung in Beispiel 1 Seite 2, B4 S1,
B7 S1 und B2 S1

| Messages x
Funktion:
Ausfiihrliche Meldungen und Dialoge === J [ Uodste Messages |
unmittelbar nach der Anwendung eines 20 |, PlugIn: | shapPaints
Filter- Plugins, sind nur schwierig und Messages
umstandlich durchzufihren. Von & selektierten Paths

Nur zwingend notwendige Fehlermeldungen,
z. B. nach einem Programmabbruch werden
durch Filter- Plugins selbst ausgefthrt.
Deshalb wurde eigens dafir dieses Plugin
bereitgestellt.

Nach jeder Ausfiihrung eines Filter- Plugins werden die nennenswerten Ergebnisse oder
Vorkommnisse gespeichert. Mit Update Messages kénnen die Ergebnisse der letzten

und mit <<< die der friheren Ausflihrungen eingesehen werden.

Messages und Inform werden (leider) auch als Plugin- Ausfiihrungen mitgezahit.

Wird in das Feld unter <<< eine 0 eingegeben und anschliessend ein Update Messages
getatigt, werden alle gespeicherten Messages geldscht.

Plugins ausgefuhrt via Place, Exports, Window und Icons kénnen keine Informationen
nach Messages.aip transferieren. Im Beispiel 7 Seite 1 wird die (umstandliche) Hand-
habung einer Fehlermeldung bei einem Import via Place demonstriert.

und 27 selektizrten Punktan
und bei 3 Knoten
wurden 10 Punkte bewegt,



_ _ Seite 3
SelectinsideArea.aip

Aufruf: Filter > Data Harmonization > Select Inside Areas

Anwendung in Beispiel 6 Seite 6
. Ebene mit den Auswahlflaechen:  |Seen (mittel) v
Funktion: | =l
. . Zusarnmengesetzte Flachen werden wie Einzelflachen behandelt!
komplett: mit dem Zentrum: mindestens mit
einem Punkt:

Es werden nur die Path- Objekte selektiert, welche

mindestens mit einem Punkt = | innerhalb der Flaechen liegen.

komplett
rnit dem Zentrum Cancel ll OK I

mindestens mit einem Punlct

Auswahl-
flache

Plugin Messages:
d 9 20 | Plugln: | selectInsidefreas

Meszages
&Anzahl selektierter Path - Objekte: 3
Vorgesehene Erweiterungen:
Zusammengesetzte Pfade



SelectBySameGeometry.aip

Seite 4

Aufruf: Filter > Data Harmonization > Select by same Geometry

Anwendung in Beispiel6 Seite7 und B8 S1

Funktion:

Alle Path- Objekte, welche innerhalb einer
Toleranz identisch sind, werden selektiert.
Wenn die gefundenen Path- Objekte jeweils
Teil einer Gruppe sind, kdnnen auch die
kompletten Gruppen selektiert werden.
Rotierte Path- Objekte werden nur innerhalb
der Prifgenauigkeit erfasst.

Select zame paths »

Select came paths
Select complete groups

Select same paths Select complete groups

R oy
' o

mYy a

vorselektiertes Path

Plugin Messages:

Fehlermeldung:

Vorgesehene Erweiterungen:
Rotation der Objekte mit einbeziehen

Select by same Geometry

Alle zum selektierten Path identischen Path- Objekte werden
selektiert. Falls diese Paths jevweils Teil einer Gruppe sind,
koennen auch die kompletten Gruppen selektiert werden.
Die graphischen Attribute werden nicht beruecksichtigt.

Select same paths

Pruefgenaugkeit in mm:

[0.01 mm

32 | Pluglm: | selectBySarmeSeometry
Meszages

Anzahl selektierter Path- Objekter 11
aAnzahl selektierter Gruppen: 4

Plug-in Error,

Bitte nur ein einziges Path fiir diese Funktion
selektieran!

Diies gilt auch flr Path-Objekte innerbalb einer Gruppe.




Seite 5
keepSelectedByGeometrie.aip

Aufruf: Filter > Data Harmonization > Keep Path selected by Geometry

Anwendung in Beispiell Seitel SR P SRR Ty S

Alle selektierten Path- Objekte werden auf inre geormetrische
Anordnung gepraft. Alle nichtzutreffenden Cbjekte werden

Funktion: deselektiert,

Deselekflert alle _Obj_ekte, b(_el denen keine der R ——
ausgewahlten Krltel‘len Zutl‘lfft |_ (Zeschlossene Path- Objekte

Bei lagegleichen Kopien wird eine Kopie ent- B P (Gl e e B
selektiert, sofern alle identischen Objekte auf [ Zukleie Paths? Quadratsette< [0.5 mm

einer Ebene liegen.

Sind sie auf verschiedene Ebenen verteilt, so
muss der Anwender entscheiden, was ge-
l6scht werden soll.

Um eine Kontrolle Uber die Ursachen fir

YWerdeckte Path- Objekte (Strakes) |
|I1 Lagegleiche Paths (Kopien) incl. I ident. Tangentenpunkie?

[™ Echte Untermengen von Path- Objekten (Fragmente?

v aufeinanderfalgende, lagegleiche Punkie 18schent

die selektiert verbleibenden Objekte ZU v Sollen die geldschien Punkte markiert werden?
behalten, sollte fur jede “Geometrische — |

Auswahl” eine getrennte Ausfiuihrung dieser
Funktion vorgenommen werden.



Seite 6
keepByName.aip

Aufruf: Filter > Data Harmonization > keep Select By Name

Anwendung in Beispiel 6 Seite 6

Funktion:
Alle Objekte welche in ihrem Namen das =~ i
Vorgegebene TeXt_StUCk ('n_g) anwe'se_n’ Mur die Objekte bleiben selektiert, welche i Marmen
veBrbIelben nach diesem Dialog selektiert folgender Text aufweien: [ing
Z.b.:
Ir.-' o L] @Kreuzlingen @D Cancel I | O I
. _,,*"D s m Singen @D
{ ::, i '_; L] m Crssingen (@] =]
=
. @ enos o 26 . PlogInt | keepSelectedByManne

Mezzages

Won 7 oselektierten Path's
werbleiben 4 selebtiert,

Plugin Messages:



_ _ Seite 7
snhapPoints.aip

Aufruf: Filter > Data Harmonization > Snap Points

Anwendung in Beispiel 1 Seite 3, B3 S3

und B7 S6

Funktion:

Bei Unterschreitung der eingegebenen _ _ _

. A . Punkte verschiedener Objekie werden entweder durch Ausmitteln oder durch

Distanz werden entweder die Punkte zweier SR UOHekis GRS L et o gl

Oder mehrerer Paths ausgemlttelt Odel’ d|e tLayer Tit gesch'Liltzten Objektt.an? |MARKIEHI_ING Foint Elimination ;I
N Diie Snapdistanz(radial) sollte geringer als das IUlllTll'ﬂ—

Punkte der ungeschutzten Layer Werden kirzeste Pathsegment sein. Distanz in mm:

denen des geSChUtZten Layers angeglichen_ I~ Sollen die 'gesnappten’ Punkte rmarkiert werdan?

Die Punkte eines Paths untereinander Cancel |

beeinflussen sich nicht. Alle selektierten
Punkte werden in einem Aufruf bericksichtigt.

Beispiele:

] Layer mit geschitzten Objektent

Snap Distanz \//

Layer mit geschitzten Objektent buildings

y

Zur Kontrolle von visuell nicht mehr erkenn-
baren Korrekturen kénnen Markierungen
angebracht werden. Diese sind in einem
seperaten Layer (MARKIERUNG SnapPoint)
untergebracht. Die Markierungssymbole bzw.
-Layer sollten gelegentlich geléscht werden.

L&

Plugin Messages: Warnung:
19 |+ Pluglm: | znapPoints Plug-in Warning
Mezzages

. Segmente sind kirzer als die Snap-Distanz.
Yon 14 selektierten Paths Dies kann zu unerwarteten Ergebnissen fihren!
und 201 selektierten Punkten

und bei 13 Enoten

wurden 18 Punkte bewegt,




Seite 8
closePath.aip

Aufruf: Filter > Data Harmonization > Close Path Objects

Anwendung in Beispiel 7 Seite 7

Funidion;

Einzelne offene Pathobjekte werden geschlossen, | pa, objexte werden geschiossen,

entweder durch Erganzen oder durch Ausmitteln, | eftweder freh frasenzen it efnem

sofern die vorgegebene Snapweite unterschritten | durchdas Ausmitteln der Endpunkte: Ausmitteln
wird. Die Snapweite ist nur beim Ausmitteln -
wirksam. Beim Erganzen wird jeweils der Start- Snapwerts s
punkt mit dem Endpunkt unabhangig ihrer
Distanz zueinander durch ein zusatzliches

Segment verbunden.

Beispiele: Erganzen: Ausmitteln:

NG 80 0«

Hinweise: Das Plugin Improve Beziers and Lines bietet ebenfalls die Moglichkeit zum
Schliessen von Pathobjekten.
Mit AreaBuilder konnen aus mehreren offenen Pathobjekten Flachen
gebildet werden.

Plugin Messages: 26 |« PlugIn: | Schliessen won Paths

Meszzages

anzahl offene Path: 9
&Anzahl meu geschlossener Paths: 4



_ _ Seite 9
AreaBuilder.aip

Aufruf: Filter > Data Harmonization > AreaBuilder

Anwendung in Beispiel 1 Seite 4

Zur Flachenbildung ‘wierden alle rniglichen Kormbinationen getestet. Jedoch
nur die innersten Flachen werden generiert.

FU n kt| on: U die Laufzeiten ertraglich zu gestalten, sollte die Anzahl der Ob jekte mogichst
gering gehalten und die Geometrie vorher mit ‘Paoint Elimination’ und '‘Connect

Aus mehreren offenen Path- Objekte werden  Patn’'bereinigt werden!
geschlossene Path- Objekten erzeugt, sofern

) . . Layer fiir erzeugte Flachen: Gerneindeflachen =]
die Endpunkte der einzelnen Path- Objekte
lagegleich sind. Gegebenenfalls sollte eine P T i Pl ket ercent 19
Bereinigung mit Snap Points voraus durch- Maximale Laufzeit in Sekunden, welche Sie in Kauf nehmen? [t
gefuihrt werden. el |

Zur Begrenzung der Laufzeiten sollte die
Anzahl der beteiligten Path- Objekte fur
die komplexeste Flache angegeben werden. Flachen aus sehr vielen Paths (>20) sollten
separat erzeugt werden. Es es ist Empfehlenswert die maximale Laufzeit auf 10 Sekunden
zu belassen. Sind 10 Sekunden zu kurz (keine Flachenbildung), kann via Messages

die erforderliche Laufzeit abgefragt werden. Die Laufzeiten werden vom Plugin hochst
ungenau geschatzt (Faktor 10 nach unten wie nach oben).

Erfolglose Beispiele:

OO

Offene einzelne Path sollten via Zuerst mit Snap Points Die einzelnen Path- Objekte soll-
Close Path Objects oder Enden lagegleich setzen. ten identische graphische Atribute
Improve Beziers and Lines haben (Farbe,Dicke,etc.) und
geschlossen werden. zur gleichen Ebene gehoren.

Plugin Messages:
22 |. PlugIn: | sreaBuilder

Mezzages

Yaon 42 selektierten Paths

und 2662 selektierten Punkten

und bei 30 getesteten Flaecherwarianter
wurden 11 Flaechen erzeugt,
Ungefashre Laufzeit in Sekunden: 2



Rectify.aip
Aufruf:
Anwendung in Beispiel 9 Seite 3 und B4 S1

Funktion:

Geschlossene Path- Objekte werden nach
einer ausgemittelten Vorzugsrichtung
rektifiziert (rot).

In diesem Beispiel werden Segmente

mit Abweichungen > 15 Grad von der
Vorzugsrichtung nicht rektifiziert (— ).

' N

Referenzgerade

Plugin Messages:

Fehlermeldungen:

Vorgesehene Erweiterungen:
Mehrere (max. 3) Vorzugsrichtungen.

Seite 10

Filter > Data Harmonization > Rectify closed Path

Geschlossene Path- Objkte rechtwinklig ausrichten

Mazirnal beriicksichtiote Abweichung in Altgrad: ' 15 |

[l orientieren der rektifizierten Gebiude nach einer Referenzgerade

Diie Referenzgerade bestent entweder aus einern selektierten Teil-
stuck eines offenen Pathobjekts oder aus einem zwei Punkte- Path.
Die Gebaude durfen durch die Referenzgerade nicht geschnitten

warden!

Orientieran der rektifizierten Gebaude nach einer Referenzgerade

Positionieren zur Referenzgerade mit derm Abstand:

Die Funktionen Orientieren (Ausrichten)
und Positionieren auf eine Referenzgerade
werden ausfuhrlich im Anwendungsbeispiel
B9 S3 erlautert.

- Plugln: | RLctify (ho one specified |

Mezzages

| Anzahl anzupazsende Flaechen: 15 |

Plug-in Error

Plug-in Error

Entweder ein Path-Objekt mit 2 Punkten oder
2wel Punkte eines grosseren Path missen
seleldtiert sein!

Zur Ausrichtung bitte exakt eine
Punktverbindung{Segment) selektieren!

o



Seite 11
PointElimination.aip

Aufruf: Filter > Data Harmonization > Point Elimination (excl. Nodes)

Anwendung in Beispiel 2 Seite 1 und B3 S1

Richtungsunabhangiges Entfernen von Punkten.

F u n ktl 0 n: Knotenpunkte (Z_L!sammenftlhrungen won gwei oder mehreren Pathenden)
. . . werden nicht gelascht,
GegenUber den meISten punktredUZIerenden Maximale Abweichung, bei der noch geldscht wird: IW

entspricht der Hohe des Dreieckes P[j-1]. P[], P[j+1]
[ Winkelabwaichung in Altarad: |3[|

™ Sollen die geldschten Punkte markiert werden?

Methoden (lllustrator, Freehand, etc.) arbeitet
diese Funktion richtungsunabhéangig. Fur die
Bearbeitung von angrenzenden Flachen

™ Erwarten Sie orthogonal und/oder symetrisch angeordnete Segmente?

|St dIeS elne unbedlngte NOtwendlgkeltl Yorsicht! Die Koordinaten werden bis zu 0.001 mm verandert.
Zudem werden vorhandene Knoten geschutzt Cancel |

d. h. lagegleiche Punkte verschiedener Path-
Objekte bleiben erhalten auch wenn sie
gemass den Parameter gel6scht werden
mussten.

Explizite Knoten:

!

geschitzte Knoten

/

Implizite Knoten:

Plugin Messages:
4 | PlugIm: | PaintElimination

Messages
Anzahl bearbeiteter Paths: 126
anzahl geschustzter Flagchenknoten: 2
anzahl gelosschter Punbta: 18831
anteil in Prozent: 77



connectPath.aip

Seite 12

Aufruf: Filter > Data Harmonization > Connect Paths

Anwendung in Beispiel 1 Seite 2 und B3 S3

Funktion:

Offene Path- Objekte werden zu einem Path
zusammengefasst, sofern sie identische
grafische Attribute besitzen und sich in der
gleichen Ebene befinden. Ausserdem mussen
die zusammengehorigen Endpunkte lagegleich
sein (Snap Points).

P3 P2
pa] Lp2
P ,ﬁ’ )_él

Mit dieser Funktion kbnnen keine geschlossenen
Path’s erzeugt werden (AreaBuilder).

Sollte ein geschlossenes Path- Objekt mit einem
bestimmten Punkt Starten resp. Enden, kann

dies mit den folgenden Schritten erreicht werden:

nach Connect Path Close Path Objects

Plugin Messages:

Spezielle Knoten |, "Zuflussknoten’, bestehen aus der YWerknuepfung zweier Fath-
Objekten mit gleicher Symbolic und Layerzugehoerigkeit mit einern Path
unterschiedlicher Syrmbolic und Laverzugehoerigkeit.

Beidiesen Knoten koennen die Path- Objekte mit den identischen Attributen, wie
Seeufer, Hauptfluesse etc., verbunden werden oder sie blejben getrennt.

I+ Sallen die Path getrennt bleiben?
Cancel | Ok |

Iv Sollen die Path getrennt bleibens

Die Frage: “Sollen die Path getrennt
bleiben?” hat keine Bedeutung, sofern
P1, P2 und P3 die gleichen graphischen
Attribute haben. Der Knoten zwischen
den drei Path - Objekten bleibt erhalten.
Falls P2 und P3 sich von P1 unter-

scheiden, werden bei

P2 einem I” P2 und

P1
P3 zusammengefasst.
Bei einem & wirde der
P3 Knoten erhalten bleiben.
4 |, PlugIn: | PointElimination
Meszages

Anzahl bearbeiteter Paths: 126

Anzahl geschuetzter Flaechenknoten: 2
anzahl geloeschter Punkte: 16631
anteil in Prozent: 77



Seite 13
Adaption.aip

Aufruf: Filter > Data Harmonization > Adaption to one Path
Anwendung in Beispiel 1 Seite 2 und B3 S2

Funktion:

Mehrere Pathobjekte, geschlossene oder offene,

werden an ein Referenz- Objekt angepasst. e e o
Dieses Path muss sich in einer separaten

Ebene, der Referenzebene, befinden. Aktive Distanz. [psmm

Adaption wurde fur geradlinige und Bezier- Moegliche Referenziaver:  [Fiuesee (iocken) <
Kurven entwickelt. Bei Bezierkurven missen

an Verzweigungen eventuell die Tangenten Cancel | _ x|

korregiert werden.

Falls die Dichte der anzupassenden Segmente
sich von der Dichte der Referenzsegmenten
stark unterscheidet, missen zusatzliche Anker- ~ f
punkte eingefugt werden, entweder einzeln 6 Punkte 48 Punkte
(Add Anchor Point Tool) oder auf alle Segmente

der selektierten Path- Objekte via
Object > Path > Add Anchor Points.

Plugin Messages:

67 | PlugIn: | adaption to one specifies

Meszsages zuwenig Punkte

Arzahl anzupassende Paths: 1

geloeschte Punkte: &

zweimal
Objekt > Path > Add Anchor Points



_ Seite 14
setNodes.aip

Aufruf: Filter > Data Harmonization > Set Nodes By Disconnect Path Objects
Anwendung in Beispiel 1 Seite 4 und B1 S5

Funktion:
U € bera” d ort \_NO Path ) O bJ e kte l ag eg I eic h e Falls Ankerpunkte verschiedener Pathob jekte identische Positionen aufweisen,
Punkte aufweisen, werden sie aufgetrennt. SRR

. . . Geschlassene Path werden gedffnet.
An diesen Positionen entstehen (fiktive) st en oF i =
Knoten. v Markieren der neuen Knoten p— |

P3

P1
==>

Elemente in geschiitzten Layers werden
benitzt, jedoch nicht verandert.

P1

Als Spezialfall kbnnen mit dieser Funktion
Path- Objekte an allen Punkten aufgetrennt
werden.

P

- Copy

- Paste in Front (Back)

- Beide Path- Objekte selektieren

- Set Nodes By Disconnect Path Objects

- KeepSelectedByGeometry
(lagegleiche Paths)

P2 p3 - Clear (Delete)

=

P1

s

Plugin Messages 23 |, PlugIn: | Set Modes
Meszages

Eei 11 selektierten Paths

und 1025 selaktierter Punkten
und bei 431 Knaten

wurden 11 Pathobjekta,

in 873 Pathobjekte zerlegt,



LineToBezier.aip

Aufruf: Filter > Data Harmonization > Line To Bezier

Anwendung in

Beispiel 2 Seite 2, B3 S1, B3 S3 und B4 S1

Funktion:

Path- Objekte, Geradenverbindungen oder
Bezierkurven, werden in Bezierkurven mit

symetrischen Tangenten umgerechnet.

Bei zu grossen Winkelanderungen kdnnen
die Kurven unterbrochen, d.h. unstetig

gehalten werden.

Tangentenauspragung = 0.0:

=0.5:

=1.0

Glattung =0.0 =1.0:
=05 =1.0

=1.0 =1.0

Kontinuitat = nein /\/\/_

:ja

Verzweigungen = nein

:ja

mﬁfﬁ g

|
|
\Y%

|
|
\Y%

avie
Ve

1
1l
\Y%

Tangentenauspragung (0.0; keine;: 1.0: maximal) | 1
Glattung (0.0: keine; 1.0: maximal) | 0
™ Kontinuitat - Stetige Kurven aus verschiedenen Path
[~ “erzweigungen - ZB.: Fluss in See oder Fluss in Fluss
Snapping [rrm]: | 0.01 rorn
Mur wirksam bei Kontunitat und /oder Yerzweigung!
[ Unstetigkeit bei Winkelanderung » [in Altgrad]: 120
Cancel |

Seite 15

Zusammen mit einer geeigneten
Snapdistanz (z.B. 0.5mm)

|\ werden Verzweigungen gebildet.

Unstetigkeit bei Winkelanderung ( > 40 Grad)

= nein

e

:ja

Plugin Messages:

==>

==>

2 |, PlugIn:

Lima To Bezier
Meszages

Anzahl Segmente: 572
Amzahl Paths: 26
Anzahl Knoten: 11



_ Seite 16
AreaNodes.aip

Aufruf: Filter > Data Harmonization > Restore Area Nodes
Anwendung in Beispiel 2 Seite 2

Funktion:

Line To Bezier interpoliert Flachen unabhéngig
der anderen Flachen. Die dabei entstehenden
Uberschneidungen werden durch Restore
Area Nodes korrigiert. Die Verarbeitung erfolgt
ohne Parameter, also ohne Dialog.

==>

Plugin Messages: € . Plugln: | Restore Area Modes

Meszages
Anzahl betroffener Flaechen: 125

Anzahl wiederhergestellter Knotan: 229

Mogliche Erweiterungen:
weitere knotenbezogen Funktionen
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BezierToLine.aip

Aufruf: Filter > Data Harmonization > Bezier To Line

Anwendung in Beispiel 2 Seite 2

. (Zusarnmengesetzte und gruppierte) Pathelemente werden linear interpoliert.
FU n_ktl on: . A Mit den untenstehenden Parameter soll die resultierende Punktmenge begrenzt
Bezierkurven werden in lineare Segmente werden.
umgereChnet E|ne maX|ma|e Abwe|Chung erlaubte Abweichung zur Kurve: IW
von der Kurve beSUmmt d|e Anzah| der maximale anzahl interpalierter Stuetzpunkteunkte innerhalb

. K . K eines Bezier- Segments: 10
zuséatzlichen Segmente abhangig von der
Krimmung. Mit dem dem"zwelten Para- conce |
meter wird bei stark gekrimmten Kurven-
segmenten auf Kosten der Genauigkeit die
Anzahl der linearen Segmente begrenzt.
==>
l == ] l Uodate Messaoges ]
Plugin Messages: 51 Plug | Bezier To Line
Mezzages

arzahl bearbeiteter Paths: 1
&nzahl Bezier- Segriente; &
arzahl interpolierter Punkte: 21



ImproveBeziers.aip

Seite 18

Aufruf: Filter > Data Harmonization > Improve Bezier and Lines

Anwendung: in keinem Beispiel

Funktion:

Im Gegensatz zu Line To Bezier, welches immer
komplette Path- Objekte verarbeitet, berticksichtigt
dieses Plugin via Lasso oder rechtem Selektpfeil
selektierte Punkte.

-~ e
Lasso

Schliessen offener Polygone funktioniert wie

Close Path Objects mit Parameter Ausmitteln,

Die Snapweite dafir kann angegeben werden.

Zusammenfassen naher Punkte fasst alle innerhalb

der vorgegebenen Distanz liegende Punkte zu einem

Punkt zusammen.

a: Alle geradlinigen Segmente erhalten
Bezier- Tangenten. Kurven mit einer
Unstetigkeit > Alfa werden neu angepasst.

b: Kurven mit Unstetigkeiten < Alfa werden
angepasst. Geradlinige Segmente bleiben
unverandert.

c: Uber alle selektierten Punkte wird neu interpoliert,
siehe Line To Bezier. Alfa hat in dieser Teilfunktion
keine Bedeutung.

d: Es werden ausser Schliessen und Zusammenfassen

(falls [#]) keine Veranderungen vorgenommen.
Warnung:

Nach undo verbleiben die vom Lasso eingekreisten
Path-Objekte komplett selektiert.

Plugin Messages:

Improve Bezier and Line Objects (Contourlines)

[ Schliessen offener Polygone Snapwaeite:

[l Zusarnmenfassen naher Punkte Distanz:
Meukonstruktion von Bezierkurven bei Punkten mit

a: fehlender Tangenten oder Tangenten it winkelabweichungen » Alpha
b: bereits vorhandenen Tangenten mit Winkelabweichungen < Alpha

c: (ber alle Punkte

d: keine Neukonstruktion

a | Gradder nterpolation(0Obis 1.0 |1 | alpha: [E6]

Hirweis: Wia Lasso kdnnen auch einzelne Punkte angesprochen werden!

Cancel

alfa> 30 Grad

® )
lineare
Segmente alfa<=30

Interpolation = 1.0

Mﬂ N

4 | PlogIni | Improve Begiers and (Cc
Mezzages
anzahl geschlossener Paths: 77
anzahl geloeschter Punkte: 816
anzahl interpalierter Punkte: 32



adjustMaps_Dialog.aip

Seite 19

Aufruf: Window > KAR Dialogs > Show AdjustMaps_Dialog

Anwendung in Beispiel 5 Seite 1 und B5 S2

Funktion:

Es wird davon ausgegangen, dass es bei
der Anpassung zweier Datenbestande aus
unterschiedlichen Quellen und eventuell
verschiedener Massstéabe, Objekte gibt,
welche in beiden Datensatzen vorkommen
und referenziert werden kénnen.

In den meisten Fallen sind dies Flussein-
mundungen in grossere Flisse oder Seen.
Selbstverstandlich sollen mit dieser Trans-
formation nur die grésseren Abweichungen
korrigiert werden.

Die massstabsbedingte Generalisierung muss
im Wesentlichen erhalten bleiben.

Plugin Messages
entsprechen denen des Plugins

|
i =

| Einpassen: = | Felsbander |

Snapweite: | 10,1 Knotenradius:| 0.5

[ Referenzlknoten ermitkeln |

Snapweite: | 10,1 Krnotenradius:| 0.5

l Einzuoazsene Knoten ermitheln J

[ Knoten neu aumehmen |

| vektoren ermitteln |

Einpazzen

D.ﬁ.ktinnsradius:
Dh'nnten aushblenden, WrinkelE
DGruppen als Symbole

Laenge: 1.0

100.0
30,0

l Einoazzen J

Anzahl Referenzknoten: 63



specialMove.aip

Aufrufe: Window > Tools > y (%

Anwendung in Beispiel 4 Seite 1

Funktion:

Seite 20

Der Radius des Wirkungsbereiches wird mit dem rechten Icon entweder am Lineal, an der
Graphik oder irgendwo im Dokument mit einer Mausbewegung im gedriickten Zustand
definiert. Er kann mit Message Dialog abgefragt werden. Diese Definition kann jederzeit

vorgenommen werden.

Mit dem linken Icon werden die selektierten Punkte bewegt, sofern sie im Wirkungs-
bereich liegen. Die Verschiebung nimmt linear vom Ansatzpunkt ab.

Anwendungsbeispiel:

Wirkungsbereich:

7 v

I\

Plugin Messages:

Mogliche Erweiterungen:

Neben einem linearen Verlauf der radialen Abnahme
koénnte eine andere Formel hinterlegt werden,

z.B. nach Gauss, logarithmisch,...

SpecialMove:

- PluglIn: | Range for Special Mowve |

Meszages
|ﬂiadius des Anwendungsbereiches: 71.7 |

- PlugIn: | Special Mowve |

Meszages

Anzahl bewegter Paths: 16
Anzahl bewegter Punkte: B02




Thm_Diagrams.aip

Aufruf: Filter > Thematic Maps > Diagrams

Anwendung in Beispiel 7 Seite 1-7

Funktion:

Setzt statistische Daten in Diagramme und
Choroplethen um.

Uber File ==> Place ==> Tab separated Excel text

file *THM) wird der statistische Datensatz eingelesen.

Im Hauptdialog werden die generellen Parameter
definiert und der grafische Darstellungstyp
(Diagramm, Symbol oder Einfarbung) ausgewabhilt.

In einem Subdialog wird die gewahlte grafische
Darstellung spezifiziert. Einige der diagramm-
spezifische Subdialoge werden im Anwendungs-
beispiel 7 naher beschrieben.

Einige Diagrammvarianten:

Plugin Messages:

Seite 21

o qu Dxfaull I
- Abing 1
Kartermassstan: | [F00000 100y [To0000 |
Erpaen | Absand suem Nulperkt 6 Dokanents. % [551730mm ¥ [3122mm |

T — P o e
maimal EZMII minimal. 2.1 rm Unterielungslinien. ﬁmm J

- :
™ Servweibwerts in Mengemwerts (oder i mimi) Mo foegtiare Farten: 5% Bt Lo Wi 125 -
[ Bescheftung?

Cancel I oK

centemerioegel
Arzahl Fleget [: el }:
St
Ter i DarteLng s Flusgals: fprm Il S e s
fuer die Unlerteing in Sekioren [orm bement sich st cen Radus
fuer geDorstetrgemes Ervetwertes:  [omm  Deeient sicn aud oe Sekiorsene.

- PlugIn: | THM: Ereissektoren

Meszages

anzahl Diagramme; 39
Arzahl Flaechan: 429




triangleMakeClasses.aip
Aufruf: Filter > Thematic Maps > Create Triangle

Anwendung in Beispiel 7 Seite 6

Funktion:

Erzeugt ein gleichseitiges Dreieck fir eine
spatere Klassenbildung von jeweils drei

Seitenlaenge des Dreiecks in mmm:

Seite 22

I]DDI‘nm

ortsbezogenen, absoluten Werten. Die etwas Unterteilng des Dretecks: 10%
aufwendige Einteilung in Klassen wird in dem
Subdialog Klassenbildung im Dreieck im

Cancel | Ik, |

Anwendungsbeispiel 7 Seite 6 vorgestellt.

Plugin Messages:

Mezzages

&7 | PlugIn: | Dreieck F Klassenbildunc

Anzahl Unterteilungen: 10
Arzahl Dreiecksfelder: 100



Seite 23
placeSymbols.aip

Aufruf: Filter > Thematic Maps > Place Symbols

Anwendung in Beispiel 6 Seite 7 und B8 S1

Funktion:
Eine G ruppe (Sym b0|) wird auf selektierte Irm Layer THI_SYMBOL_REFERENCES enthaltene Gruppen (SYMBGOL 1 bis
. SYMBOL_Z20) konnen selektierte Path's ersetzen.
Path- Objekte oder deren Ankerpunkte Falls weder THM_5YMBOL_REFERENCES norh Symbolgruppen erxistieren,
| . wird der Layer zusammen mit einem Default- Syrmbaolikreis) generiert.
p atZIert' Zwischen dieser Symbolorganisation und den Hlustrator- Symbols bestent keinen
Zusarnmenhang!
werfilghare Symbole: |SYMEBCL_T |
Plazierung der Symbale auf |die Zentren ~|
die Startpunkte
alle Punkte der Path- Objekte
1]
1l
Vv
Plazierung der Symbole auf
die Zentren: auf die Startpunkte: oder auf alle Punkte der Path- Objekte:
Default Referenzsymbol: Plugin Messages:
[] THM_SYMBOL_REFEREMCES O
) [ svmecL_t o 62 . PlogIn: | placeSymbols
[[] =path- [+ Meszages

Anzahl plazierter Symbole: 17
Benutzer definierte Referenrsymbole:

/\Qﬂloo-&
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IrregularPattern.aip

Aufruf: Filter > Thematic Maps > Irregular Pattern

Anwendung in Beispiel 6 Seitel - 5 n— _

. . Mur die im Layer THW_SYMBOL_REFEREMCES enthaltene Gruppen {symball bis
FU n kt| on: Syrnbol20) konnen gestreut werden.
Falls weder THW_SYMBOL_REFERENCES noch Symbalgruppen existieren,

D|e me|sten Stru ktu rraster enth a|ten Oft Wieder- wird der Layer zusarnrmen mit einern Default- Syrmbolikreis) generiert.
ke h re n de M USter (Tapete n) u nd an g E‘SCh n |tte ne %ﬁ:{:ﬁnﬁﬁgﬁﬁeasn%rl Symbalorganisation und den llustrator- Symbols besteht kein

Symbole. Individuelle Losungen sind in der  Symbol Defintion — -~ Raster Defintion
Re el nlCht mO IICh Symbal: in % || Grundanordnung der Syrnbale: |Orth0g0na| vl
g g ) ISumpf :IY 100 Spaltenabstand: | 2 mm Zeilenabstand: 3mm

Mit Filter > Thematic Maps > Irregular Pattern [Cstoae ] [0
kénnen sehr spezifische Strukturraster erzeugt —|[Rebsioe. =] o veristeninz

(=) =

o
I_ horizontal: 100 vertikal: T

werden, wie Walder, Simpfe, Gerdllflachen, l__lliiti L IIE: b '
Kiesgruben, Boschungen, etc. e =] [0 Eﬂ::;iifm% vertical  G.3mm
Die Funktion Strukturraster wird ausfuhrlich o '
in dem Anwendungsbeispiel 6 und in s
http://www.ika.ethz.ch/plugins/en/irregular_pattern_plug_in.pdf | Layer mit Filliflachen: =
beschrieben. Mindestabstand zum Flachenrand: [0:3mm

@ Q @ ) — Werarbaitung

¥ Sollen sich (berdeckende Symbole entflechiet werden?

— Hindernisse
™ Sollen Hindernisse beriicksichtiot werden?

Mindestabstand zu den Hindernissen: I 0.2 mm

Cancel |

Plugin Messages: 27 | PlugIn: | IrregularPattern
Meszages
Anzahl generierter Symbole: 213
anzahl Flaechen: 4
&nzahl Hindernisse: B0
Anzahl Restueberdeckungen: 0
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PointCluster.aip

Aufruf: Filter > Thematic Maps > Point Cluster

Anwendung in Beispiele 9 Seitel und 2

Funktion:
Aus Punktwolken oder aus Flachen werden  tayer fir erzeugte Fiachen: [eehr dicht ]
Cluster- Flachen gebildet. Objekttyp, Punkle oder Fldchen:  [punktiarmig (Kreisa) =]
= IMaximale Distanz benachbarter Punkte [mm]: I 1.5 mm
punktbezogen (Kreise) w
— = - Ab wieviel Punkted»=13 soll eine Flache gebildet werden? I 2
punktbezogen (Kreise)
F |-§IE|'IE|‘I Lmrisse (GEDéUdE Et'::l Stiitzpunktdichte der resultierenden Flachen: |mitte| ;l
Flachen, exakt {GED-.:_.IUEIE LBt Interpolation dar Flachenkonturen: |mmittel |
Glattung der Flachenkaonturan: -

(Kontur verlauft 2wischen den Stitzpunkten)

Anwen d un g S b ei S p | e| e: WARMUMG: Die Ausfiihrung dieses Plugins kann

IMinuten dauern!
Cancel |

Plugin Messages:

74 |, PlugIn: | PointCloster
Mezzages

anzahl erzeugter Paths: 25

Vorgesehene Erweiterungen:
Automatische Generierung von Objekten des
Typs: Zusammengesetzte Pfade (compounds)



Seite 26
AdjustSymbols.aip

Aufruf: Filter > Thematic Maps > Adjust Symbols

Anwendung in Beispiel 10 Seite 1

FU n ktl on. Tangentiales Ausrichten von Symbolen auf Path- Objekte

Ausg € hend von g?SCh l Ossen.en Path- . Zwischen _cler hier verwendelten Syrnbolorganisation und den Ilustrator- Syrmbolen
Objekten, welche innerhalb einer Snapweite S

THM- Syrnbale werden in der Ebene <THM_SYMBOL_REFEREMCES > als Gruppen

von offenen Path- Objekten liegen, werden hereitgenalten

L. ‘erflgbare Symbale: O
vordefinierte Symbole (Gruppen)
(THM SYMBOL REFERENCES) Maximale Distanz zum nachsten Path (Bahnlinig) [mm]? .D.Smm
tangential auf die offenen Path- Objekte RETCrE B R i i

ausgerichtet und platziert.

Referenzsymbole: = o - e
Default

Plugin Messages:

17 . Pluglnt | adjustSymbaols
Mezzages

Anzahl Paths(Bahnen]: 13

anzahl Symbole: 26

davon werden baweagh: 26

Vorgesehene Erweiterungen:
Angleichen an Objekte des Typs:
Zusammengesetzte Pfade (compounds)



_ o _ Seite 27
generalizeBuildings.aip

Aufruf: Filter > Data Harmonization > Generalize Buildings

Anwendung in Beispiel 9 Seite 4

Funktion:
Vorywegend recht_wmkllge Flachen werden Layer fir generalierte Getaute: [generaToerte G 3]
auf ihre Vorzugsrichtung (Modulo 90 Grad) Art der Gengralisierung: =
geprUﬂ und Je nac_h der gewahlten Anzahl Gebaude pro Reihe: ID =0: gleichbleibend
“Generalisierung” in Form von einfachen ApEAIGRKIOr (0SB0 [T
Rechtecken, Eckgebauden oder Reihen BT [roch -
von Rechtecken in die gewlnschte Ebene

: H g . CZancel
abgelegt.Die Reihen werden entweder 1:1 _Cancel |

geordnet oder auf wenige Flachen redu-
ziert dargestellt.

Mit einem Anpassungsfaktor kénnen die Plugin Messages:
resultierenden Flachen verstarkt oder
abgeschwacht werden. | === | | Uodate Messages |
26 |+ Pluglmi | Generalize Buildings)
o Mezzages
Anwendungsbeispiel: &Anzahl zusammengefasster Flichern: 13
N
& | ]
o i —
L L o
8™ oy e =
~ b B
™, ]
A7
zusammengefasste

Flachen (Gebaude)

Vorgesehene Erweiterungen:

- vorgegebene Richtungen

- z.B.von Strassen definierten Blscke
- angepasste umhillende Flachen



Seite 28
intersectByLinearPath.aip

Aufruf: Filter > Data Harmonization > Intersection by linear Path Objects

Anwendung in Beispiel 11 Seite 2

Funktion: Intersection; by linear, Path Objects

Mit linearen Path- Objekten, geschlossene
Alle auf den Intersect-Pathobjekten liegenden Path-Cbjekte erhalten

(Schnittflachen) wie auch offene (Schnitt- 2usitzliche Schnittpunkte.

kanten), konnen belleblge Path- ObjEkte, [¥]5allen die Path-Objekte aufgetrennt werden?

incl. Bezierkurven, geschnitten werden. Laser it SEIRRTIceten erseCt Rotist | Bezirksflachen A
Die bearbeiteten Objekte werden entweder | FzaigeltEeeinuseen i et Segreten 2
aufgetrennt oder durch die Schnittpunkte

erweitert.

Schnittpunkte

—~J

Plugin Messages:
9 9 70 | PlugIn: | Intersection by linear Pa

Mezzages

Anzahl Schnittpunkte: &
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Fels_Parameter.aip

Aufruf: Window > KAR Dialogs > Felsbander Dialog

Es existiert fur dieses Plugin kein
Anwendungsbeispiel.

Funktion: =
Ausgegangen wird von einem oder mehreren | Felsbander = =
offenen Path-Objekten. Die Objekte mussen  Felsbander, geometrisch definiert durch

. .. puriktgleiche COber- und Unterk antzn
eine gerade Anzahl von Stiutzpunkte

aufweisen. Beleuchtung: Lichtzeite ev
Die erste Halfte eines solchen Path definiert Felsobjekt: gross v
die Lage der Oberkante, die zweite Halfte el kanwvex v
di_e der Unterkante eines Felsbandes. [ Strichstirken festiegen

Die Art_der Beleuc_htung und der Parameter ctrichatarken in mm

Felsobjekt legen die Grundwerte fur die o ooz 1o oz 1o

verschiedenen Strichstarken fest.
Danach kann der Anwender die vorgegeb-

enen Strichstarken noch abandern und Skalierung der Strichstarken auf| jon | %
. . . . .. Mazke?
zusatzlich skalieren und eine Maske fiir den A
Hintergrund generieren. | Felsbinder erzeugen
reldungen

Beleuchtung =

konkav linear konvex



areaCalculation.aip

Aufruf: Filter > Data Harmonization > Area Calculation (incl. Bezier)

Anwendung in Beispiel 8 Seite 3

Funktion:

Die Flachen geschlossener Path und einfach
strukturierter Compound Path werden in
Millimeter berechnet und als Text in der
generierten Ebene calculatet areas
festgehalten.

Komplexere Compounds, zum Beispiel
zusammgesetzt aus Exklaven, Enklaven und
Ueberschneidungen von Flachen,

missen sinnvollerweise aufgeldst und als
einfache Path- Objekte berechnet werden.

Plugin Messages:

Seite 30

Einfache Paths: §0:85
135.1
6.61
Einfache struktuierte
Compounds: 1526 117.7
139.2
Komplex strukuierte 0 o
Compounds: )
Hat- 10.85
aufgelost: 1351 1351
6.61 6.61
10.85
l 2= ] l Update Meszages ]
g4 | PlugIn: | Area Calculation
[Meszages

Anzahl berechneter Flaechen: 24

davon zusarnmengesetzte Flichen: 4
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