Erganzende kartografische Funktionen fur lllustrator CS

Die am Institut erstellten kartografischen Funktionen sind als Plugins in das Grafikprogramm lllustrator CS
integrierbar. Sie werden laufend erweitert und sind in der Home Page des Instituts unter

Dienstleistungen > Downloads > Plugin’s fiir lllustrator >Plugins fir lllustrator CS 2 (12) als ZIP - File
verfuigbar. Die Plugins sollten in einem Unterordner, z.B: plgl2_CS2, in den Ordner Plug-ins abgelegt werden.
Waérend des Transfers darf lllustrator nicht gedffnet sein! Auf keinesfalls diirfen Plugins gleichen Namens
mehrfach unter der Hierarchie Plug-ins vorhanden sein, deshalb: Immer den ganzen Ordner plg12 ersetzen.

In den folgenden sieben Anwendungsbeispielen werden die meisten der verfligbaren Funktionen eingesetzt.
Abschliessend werden noch alle unter lllustrator CS (12) einsetzbaren Plugins kurz vorgestellt.

Beispiel 1 Thema: Aus unbereinigten Daten Fldchen bilden
beteiligte Plugins:
Selected.aip aufgerufen durch Window > KAR Dialogs > Show Inform Dialog
keepSelectedByGeometry.aip Filter > Data Harmonization > Keep Paths selected by Geometry

Beispiel 2:

Beispiel 3:

Beispiel 4:

Beispiel 5:

Beispiel 6:

connectPath.aip
Messages.aip
Adaption.aip
snapPoints.aip
setNodes.aip
AreaBuilder.aip

Importierte Daten reduzieren
Selected.aip
PointElimination.aip
Messages.aip
AreaNodes.aip
LineToBezier.aip
BezierToLine.aip

Bestehende Karte verbessern
PointElimination.aip
LineToBezier.aip
Adaption.aip
shapPoints.aip
connectPath.aip

Anpassen durch zirkulare Transformation

specialMove.aip
Messages.aip
LineToBezier.aip
Rectify.aip

Filter > Data Harmonization > Connect Paths

Window > KAR Dialogs > Show Messages Dialog

Filter > Data Harmonization > Adaption to one Path

Filter > Data Harmonization > Snap Points

Filter > Data Harmonization > Set Nodes By Disconnect Path Objects
Filter > Data Harmonization > AreaBuilder

Window > KAR Dialogs > Show Inform Dialog

Filter > Data Harmonization > Point Elimination (excl. Nodes)
Window > KAR Dialogs > Show Messages Dialog

Filter > Data Harmonization > Restore Area Nodes

Filter > Data Harmonization > Line To Bezier

Filter > Data Harmonization > Bezier To Line

Filter > Data Harmonization > Point Elimination (excl. Nodes)
Filter > Data Harmonization > Line To Bezier

Filter > Data Harmonization > Adaption to one Path

Filter > Data Harmonization > Snap Points

Filter > Data Harmonization > Connect Paths

el
™

Window > KAR Dialogs > Show Messages Dialog
Filter > Data Harmonization > Line To Bezier
Filter > Data Harmonization > Rectify closed Path

Lokale Transformation mit gewichteten Vektoren

AdjustMaps_Dialog.aip

Strukturraster
[rregularPattern.aip
selectinsideArea.aip
keepSelectedByName.aip
selectBySameGeometry.aip
placeSymbols.aip

Window > KAR Dialogs > Show Einpassen Dialog

Filter > Thematic Maps > Irregular Pattern

Filter > Data Harmonization > Select Inside Area

Filter > Data Harmonization > Keep Selected By Name
Filter > Data Harmonization > Select By Same Geometry
Filter > Thematic Maps > Place Symbols



Beispiel 7: Thematische Karten (THM)
Messages.aip
Thm_Diagrams.aip
triangleMakeClasses.aip
snapPoints.aip
closePaths.aip

Beispiel 8: Symbole und Diagramme (THM)
Thm_Diagrams.aip
selectBySameGeometry.aip
placeSymbols.aip

Window > KAR Dialogs > Show Messages Dialog
Filter > Thematic Maps > Diagrams

Filter > Thematic Maps > Create Triangle

Filter > Data Harmonization > Snap Points

Filter > Data Harmonization > Close Path Objects

Filter > Thematic Maps > Diagrams
Filter > Data Harmonization > Select By Same Geometry
Filter > Thematic Maps > Place Symbols

Beispiel 9: Flachen aus Punktwolken, Geb&dude bearbeiten

PointCluster.aip
selectBySameGeometry.aip
Rectify.aip
generalizeBuildings.aip

Filter > Thematic Maps > PointCluster

Filter > Data Harmonization > Select By Same Geometry
Filter > Data Harmonization > Rectify closed path

Filter > Data Harmonization > Generalize Buildings

Beispiel 10: Angleichen von Symbolen an offene Path

adjustSymbols.aip

Filter > Thematic Maps > Adjust Symbols
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Beispiel 1: Aus unbereinigten Daten Flachen bilden

Bereinigung der Topologie

Auch fur das Auge perfekte Karten weisen in ihren Daten oft eine tUiberraschend hohe Anzahl Fehler auf.
Bei einer Weiterverwendung mit einem GIS wiirden diese inkonsistenten Daten zu grossen Schwierig-
keiten flihren und waren dort nur umstéandlich zu bereinigen. Da sie kaum oder nicht sichtbar sind,
kdnnen diese Fehler auch mit lllustrator- Funktionen nur mit viel Aufwand behoben werden.

Zunachst wollen wir Gber die beteiligten Objekte
eine Ubersicht gewinnen:

<B1Start.ai>

Window > KAR Dialogs > Show Inform Dialog

Einpaszen: ™, Maz=zages q Selected |

LIE-:Iate Infio I

Total nurnber of objects:

— Dbject types
Simple pathes: &

I Tz
OpErn: I &0 closed: I 2
5traight:| 45 Beziar: I 14

I‘

Carmpound objects: I':'—

aFoups: I”—

Layers: I_II,—
Fehlerhafte Kartengrafik [ Sentents

Wertices: Caz

Fathz within cornpound objects: I 0

Filter > Data Harmonization > Keep Paths selected by Geometry
Keep paths selected by geometry

Alle selektierten Path- Cbjekte werden auf ihre geometrische
Anordnung geprueft. Alle nichtzutreffenden Objekte werden
deselektiert,

Geometrische Auswahl:

[~ @eschiossene Path- Cbjekte

v Path- Objekte mit nur einem Punkt

V¥ Zukleine Paths? Quadratseites |D.5 M

Werdeckie Path- Ob jekie (Strokes) |
v Lageqleiche Paths (Kapien) incl. [ ident. Tangentenpunite?

Iv Echte Untermengen von Path- Objekten (Fragmente?)

v Aufeinanderfolgende. lagegleiche Punkte loeschen?

© ®e 6

v Sollen die geloeschten Punkte markiert werden

Cancel |
Die selektiert verbleibenden Objekte werden
verifiziert und entsprechend geldscht. Selbstverstandlich werden in der Praxis die hier
Von den Kopien (3) wird nur eine entfernt vorgenommenen finf Tests nacheinander
(Grenzen im See). durchgefiihrt.
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Die fur die einfache Grafik immer noch hohe Zahl (53) an Path- Objekten und eine genauere Kontrolle
zeigen, dass mehrere Gemeindegrenzen und Fllsse bei gleichen Strichstdarken unnétigerweise

aufgeteilt sind.

Bereinigung der Grafik

Filter > Data Harmonization > Connect Paths

Conneck Paths

Spezielle Knoten ,"Zuflussknoten’, bestehen aus der Yerknuepfung 2weier Path-
Cbjekten mit gleicher Symbolik und Layerzugehoerigkeit mit einerm Path
unterschiedlicher Symbolic und Layerzugehoer igkeit.

Bei diesen knoten koennen die Path- Objekte mit den identischen Attributen, wie
Seeufer, Hauptfluesse etc.. verbunden werden oder sie bleiben getrennt.

Zancel | [o]% |

[ Sollen die Path getrennt bleiben?

Window > KAR Dialogs > Show Messages Dialog
=S
Messages b

== | Update Massages I

Iq.— Plugln IcunneciF"aih

MWeszage=s

anzahl verbundener Faths: 2
fnzahl geschustzter Knoten: 149
fnzahl wegfallender Paths: 12
anzahl untersuchter Paths: 52

18 Paths werden zu 8 Paths zusammengesetzt.

Fir eine anschliessende geometrische
Bereinigung ist dieses Zusammenfassen von
Paths mit gleichen Layer, Strichstarke und
Farbe unumgénglich.

An den mit Pfeilen gekennzeichneten Stellen
sollen die Gemeindegrenzen an die Flisse
angepasst werden.

An ein Fluss- Path konnen mehrere Grenz- Path
angeglichen werden.

Filter > Data Harmonization > Adaption to one Path

Path- Objekte anpassen

Geschiossene oder offene Path- Elemente werdenan e in
durch einen Layernamen spegifiziertes Path angepasst.

Altive Distanz: IEI.S mm

Moegliche Referenzlayer: |F|uesse {locker) j

iZancel | oK |

Flussabschnitt (jeweils aus einem Path bestehend)
fir Flussabschnitt wird die Karte abgearbeitet.

Bei Verwendung von Bezierkurven missen

die Verzweigungen kontrolliert und gegebenen-
falls durch Verandern der Tangenten nach-

gebessert werden.
é/
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Path- Objekte anpassen

Geschlossene oder offene Path- Elemente werdenan e in
durch einen Layernarnen spezifiziertes Path angepasst.

Alktive Distanz: ID.S i

IMoeqgliche Referenzlayer: |Gemeindegrenzen LI

Cancel | Ok |

Bei dieser Selektion werden nur die Gemeinde-
grenzen als Referenzlayer angezeigt.

Der Fluss erscheint nicht, da dieser als Gruppe

aus zwei verschieden dicken Paths besteht und
deswegen nicht zusammengefasst werden konnte.
In dieser Situation muss zwingend das rechts
angeordneten Direkt Auswahl Werkzeug

benitzt werden.

Generell sollten nur die zur Anpassung bendtigten
Paths selektiert werden.

Ein weiteres Problem sind die grafisch scheinbar
einwandfreien Verzweigungen.

Die hier aufgezeigte
Abweichung verhindert
spater eine komplette
Erzeugung von Gemeinde-
flachen.

Mit einem ‘Snapping’aller
Punkte um eine kleine Weite

von z.B. 0.1 mm werden solche Konflikte beseitigt.

Filter > Data Harmonization > Snap Points

Snap Points

Punkte verschiedener Objekte werden entweder durch Ausmitteln oder durch
‘ansnappen’ an Objekte geschuetzter Laver beweqgt.

[ Layer mit geschuetzten Chjekten? |Guides j

Die Snapdistanz(radial) solite geringer als das Im M
kuerzeste Pathsegrment sein. Distanz in mim:

Iv Sollen die ‘gesnappten’ Punkte markiert werden?

Cancel | 0 |

An zwolf Positionen wurden
29 Punkte bewegt.

Es empfiehlt sich die ent-
sprechenden Stellen zu
markieren.

Nach einer sorgfiltigen
Uberpriifung sollten die
Markierungen wieder
geldscht werden.




Flachenbildung

Da jedes Path mit jedem Path zu prifen, rasch
zu einer sehr hohen Laufzeit fihren kann,
versucht man diese einzuschranken.

Mit 15 werden von jedem Path aus die topologisch

15 ndchsten Path- Objekte zur Flachenbildung
beigezogen.Werden bei korrekten Daten einzelne
Flachen nicht erzeugt, so ist dieser Wert zu
erhéhen.Bei 10 werden bei diesem Beispiel
nicht alle Flachen gebildet.

Eine weitere Absicherung vor zu langen Lauf-
zeiten ist ein vorgegebener, ungefdhrer
Zeitrahmen, in diesem Beispiel 10 Sekunden.
Falls nichts ausgefiihrt wird, erfahrt man die
vorzugebende Laufzeit und entsprechenden
Ratschldge via Messages.
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Fir die Flachenbildung missen an den
Verzweigungen Knoten gebildet werden,

d.h. der Walensee und verschiedene Grenzlinien
werden zerlegt. Mit den Gemeindegrenzen gemein-
sam verlaufende Fluesse (dicht, mittel, locker)

sind zu schliessen, da sie sonst segmentweise zerlegt
wirden und zur anschliessenden Flachebildung
nichts beitragen kdnnten. Nur Gemeindegrenzen

und Seen (locker) bleiben offen.

Filter > Data Harmonization > Set Nodes By Disconnect Path- Objects

Set Modes By Disconnec

Falls Ankerpunkte verschiedener Pathobjekte identische Positionen aufweisen,
wirden die Pathob jekte aufgetrennt.

Geschiossene Path werden geoeffret.

[~ Layer mit geschuetzten Objekten? Kantonsgrenzen =l

v Markieren der neuen Knoten
Cancel | 8]4 |

Nach einer eingehender Uberpriifung der neuen
Knoten sollte diese wieder entfernt werden.

Filter > Data Harmonization > AreaBuilder

AreaBuilder

Zur Flaechenbildung werden alle moeglichen Kombinationen getestet.
Jedoch nur die innersten Flaechen werden generiert.

Lrn die Laufzeiten ertraeglich zu gestalten, sollte die Anzahl der Ob jekte
moegichst gering gehalten und die Geometrie vorher mit ‘Point Elimination’ und
‘Connect Path' bereinigt werden!

Layer fuer erzeugte Flaechen: Gemeindeflaechen j

Wiewiel Db jekte vorn zu untersuchenden Objekt enfernt sallen l—
noch fuer die Flachenbildung beruecksichtigt werden? 15

Maximale Laufzeit in Sekunden, welche Sie in Kauf nebmen?

|1U—
Cancel | Ok |

Beispiel eines “Ratschlages”

el [
Messages Selected u
= I Update Messages I
|68 Flugln IP.reaBuiIder
Mazzages
WA RN UNG

Die dusfuehrung wuoerde zu lange dauern,
ca. 4000 Sekunden

Eitte weniger selaktisren resp.

klzinere Ohjektweite eingeben

oder Vorgabezeit erhoehen!

Eine Gemeindefldche wurde nicht erzeugt und
ein Grenz- Path war nicht wirksam!

Zur Behebung der Ursachen missen die
beteiligten Knoten Gberprift werden.



<B7Start.ai>
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An diesen zwei Positionen fehlen die zur Flachen-
bildung notwendigen Knoten.

Die Snapweite von 0.1 mm war daflir zu gering.

Eine geeignetere grossere Snapweite z.B.0.5 mm
hatte zu grosse Anderungen im Grenzverlauf
verursacht. o
Vorteilhafter ist es zwei neue Punkte mit & zu
digitalisieren und diese mit einer Snapweite von

0.1 mm anzupassen (Filter > Data Harmonization > Snap Points)
und danach mit

Filter > Data Harmonization > Set Nodes By Disconnect Path- Objects
die entsprechende Grenze aufzutrennen.

Nach dieser Nachbearbeitung sollte eine erfolgreiche
Flachenbildung mdglich sein.

Mehrfach Ubereinander gelagerte Flachen

sind leicht mit der Transparenz- Funktion erkennbar.
Einfach die mehrfach Giberdeckte Flache zu
entfernen, wiirde das Problem nicht [6sen.

Meistens sind einige Knoten und/oder einige
Grenz- Path nicht korrekt.

Zuletzt sind noch die Paths des Walensees zu
selektieren und mit Filter > Data Harmonization > ConnectPaths
zusammenzufiigen.

Dieser Datensatz wird in den Beispielen 7 und 8
fUr eine thematische Karte weiterverwendet.
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Beispiel 2: Importierte Daten reduzieren

Der kleine Ausschnitt einer Bodenkarte Giberrascht durch seine grosse Punktmenge.
In diesem Beispiel versuchen wir die Punktmenge zu verringern und einerseits als Bezierkurven fiir eine
Karte zur Verfligung zu stellen und andererseits in Form von linearen Daten fiir ein GIS aufzubereiten.

<B2Start.ai>

Einpaszen: ™, Messages Y Selected |

Update Infa I
Total nurmber of objects: I 127

— iDbject types
Simple pathes: IF

Open: ID— closed: I?
straight: IT Eeziar: I':'—

Cornpound objects: l':'—
@roups: |1—
Layers: |1—
— Contents
Vartices: W

Faths within cornpound objects: I i}

167 Punkte fiur diese Flache sind zu viel.

Filter > Data Harmonization > Point Elimination (excl. Nodes)

Point Elimination

Richtungsunabhaengiges Entfernen von Punkien.

Knotenpunkte {Zusamrmenfuehrungen von 2wei oder mehreren Pathenden)
wierden nicht geloescht.

Maximale Abweichung. bei der noch geloescht wird: ID 1 mm
entspricht der Hoehe des Dreieckes P[j-1]. P[j]. P[j+1] .
‘winke labweichung in &ltgrad: I3D

[~ Sollen die geloeschten Punkte markiert werden?

Cancel | Ok |

Mit einer maximalen Abweichung von 0.1 mm

erzielen wir eine Reduktion auf 18 Punkte,

obwohl Segmente mit einer Winkeldanderung > 30 Grad

als wichtig eingestuft sind und damit nicht geléscht werden.
Auf den gesamten Ausschnitt Gbertragen, erreichen

‘ Mﬂ wir eine betrachtliche Einsparung.
7 = "”
‘r-.j% , ————

f == I Update Messages |
/ [+ Plugln |FointElimination

’ Meszages

Anzahl bearbeiteter Paths: 126

‘ /, Anzahl geschuetzter Flaschenknoten: 229

Anzahl geloeschier Punkte: 14714
Anteil in Prozent: 68
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Fir die Einarbeitung in eine Karte wollen wir
Bezierkurven

Filter > Data Harmonization > Line To Bezier

Line To Bezier

Tangentenauspraegung (0.0: keine; 1.0: maximal) )

1

Glaettung {0.0: keine; 1.0: maximal)
[~ Kontinuitaet - Stetige Kurven aus verschiedenen Path
[~ Werzweigungen - Z B.: Fluss in See oder Fluss in Fluss

Snapping [mm]: 0.01 mm
MNur wirksarn bei Kontunitaet und/oder Yerzweigung!

1

[™ Unstetigkeit bei winkelaenderung » [in Altgrad): 5

Cancel | QK

Mit einer leichten Reduzierung der Tangenten
erreichen wir ein annehmbares Ergebnis.

Bei der Interpolation werden die Knoten nicht
berucksichtigt. Es kommt daher zu stérenden
Uberschneidungen.

E

Mit dem Filter
Filter > Data Harmonization > Restore Area Nodes
werden die Knoten bereinigt.

Ein GIS- Export verlangt meistens lineare Objekte. Filter > Data Harmonization > Bezier To Line
(Zusammengesetztie und gruppierte) Pathelermente werden linear interpoliert.

Iit den untenstehenden Parameter soll die resultierende Punktmends begrenzt
werden,

erlaubte &bweichung zur kurve: Iu,l mm

rnaximale Anzahl interpalierter Stuetzpunkteunkte innerhalb

eines Bezier- Segrments: |5
Cancell 0K |

1| Nach einer Reduzierung
Messages 2 um ca. 15000 Punkten

=< |__ UhteWessaes || k3nnen fiir eine
IS Flugl IB iar To Li . .
o GIS- Weiterbearbeitung
Anzahl bearbeiteter Paths: 126 Zusatzliche ca. 800 Punkte

Anzahl Bezier- Segmente: G548
Anzahl interpolierter Punkte: 7446 ZU g em utet we rd en.




Beispiel 3: Bestehende Karte verbessern

Bestehende Karten kdnnen durch Arbeitsschritte, wie 4

Filtern, Reduzieren, Interpolieren, Vernetzen, Ersetzen, et 4

Restrukturieren, Zusammenfassen, etc. verbessert werden. e WSBREEIR 7

In diesem Beispiel werden anhand eines Ausschnitts vt =

aus einer Wanderkarte zwei solche Operationen )

durchgefihrt: 7 e -

- Wald erstzen und e

- Fusspfade (Strichlierung) zusammenfassen. #" w:‘:‘:\‘ :
| 2 & -

vt L]

Wald ersetzen I

Dieser Wald wird als Orientierungshilfe als zu v araaa:. e

undifferenziert empfunden, deshalb werden L g PR

die Waldobjekte aus dem Datensatz Vektor 25 Tt zaiias W ",

Gbernommen und in die Karte eingearbeitet.

Zundchst verschieben wir zwei Waldobjekte in die

bestmOglichste Position und schalten die Fiillung aus. Waldobjekt

Den zu detailreichen Wald vereinfachen wir mit aus Vektor 25

Filter > Data Harmonization > Point Elimination (excl. Nodes)

Richtungsunabhaengiges Entfernen von Punkten.

Knotenpunkte (Zusammenfuehrungen Yon 2wei oder mehreren Pathenden
werden nicht geloescht.

Mit Filter > Data Harmonization > Line To Bezier
werden alle Segmente interpoliert, welche eine
Winkelabwichung < 40 Grad aufweisen (B2 S2).

Tangentenauspraegung (0.0: keine: 1.0: maximal) |1
Glaettung (0.0: keine; 1.0: maximal) ID

[” Kontinuitaet - Stetige Kurven aus verschiedenen Path

[ Werzweigungen - 2 B.: Fluss in See oder Fluss in Fluss

Snapping [rmmm]: ID 01 rarn

Mur wirksam bei Kontunitaet und soder Yerzweigung!
[~ Unstetigkeit bei winkelaenderung > [in Altgrad]: IdD

Cancel | O |

Siehe B2 S2

&

7 Kamlhaden

Wpwaitah

Walligadsiel

Seite 1

IMaximale Abweichung, bei der noch geloeschi wird: ID_15 [
entspricht der Hoehe des Dreieckes P[j-1], PLil. PLi+1]
‘tfinkelabweichung in Altgrad: IE,D
I Sollen die geloeschten Punkte markiert werden?
Cancel | Ok | ;
Siehe B2 S1




Als ndchstes soll das linke Waldobjekt an eine der
Strassen angepasst werden.

Das Plugin

Filter > Data Harmonization > Adeption to one Path

Siehe
B1S2

12 05trassenu. Wege 26 =

ermoglicht das Anpassen mehrer Path- Objekte an einen
Referenz- Path. Die Anpassungen mussen folglich
interaktiv nacheinander vorgenommen werden, in diesem
Beispiel in zwei Etappen.

Im Weiteren sind noch eventuell Korrekturen an
einzelnen Segmenten (Punkte) vorzunehmen.

Die Fiillfarbe von Ebene <50.0 Wald 8> muss nach
<Wald25> tubertragen, das Objekt <50.0 Wald 8>
geldscht, die <Wald25> Kontur ausgeschaltet und die
Ebene <Wald25> in die Nahe der Ebene <50.0 Wald 8>
geschoben werden, damit die Strasse auf den Waldrand
zu liegen kommt.

Beispiel 3 Seite 2
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Fusspfade zusammensetzen

Alle sichtbaren Teile der Fusspfade bestehen in dieser
Karte aus einzelnen Path- Objekten.

Fur eine Weiterverarbeitung oder fiir den Export in

ein GIS sollte ein Fusspfad aus einem Path bestehen.

Sobald alle Ebenen ausser <506.0 Footpath 26>
geschlossen sind und die entsprechenden Fusspfad-
Objekte selektiert sind, setzen wir vier Plugins in
folgender Reihenfolge ein:

- Punkte ‘Snappen’ mit

Filter > Data Harmonization > Snap Points
Siehe B1 S3 und B7 S6

mit den Dialogeingaben:

- Kein Layer wird geschutzt,

- Snapdistanz = 0.7 mm und

- ‘gesnapte’ Punkte werden nicht markiert

- Verbinden offener Path- Objekte zu einem Path i gi
Filter > Data Harmonization > Connect Paths Siehe B1 S2

- Léschen Uberflussiger Punkte durch
Filter > Data Harmonization > PointElimination (excl. Nodes)
mit den Dialogeingaben 0.15 mm und 90 Grad.

- Interpolieren £ 4
Filter > Data Harmonization > Line To Bezier T o~
Siehe B2 S2
Tangentenauspraegung (0 0: keine: 1.0: maximal) |1— Und BS 82
Glaettung (0.0: keine; 1.0 maximal) ID—

I Kontinuitaet - Stetige Kurven aus verschiedenen Path
™ ‘erzweigungen - ZB.: Fluss in See oder Fluss in Fluss
ﬁﬂﬁwpfs[anm]e. Kontunitaet undsoder Yerzweigung! pot mm
™ Unstetigkeit bei Winkelaenderung » [in Altarad]: 180
Cancel | Ok J-

Die Strichlierung wird via Dashed Line mit dash = 1 mm

und gap = 0.7 mm eingestellt.

Selbstverstandlich muss bei

komplizierten Anordnungen in

kleineren Interaktionschritten

vorgegangen werden.

e
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Beispiel 4: Anpassen durch zirkulare Transformation

In diesem Kartenbeispiel passen Landesgrenzen (rot) B4sStart.ai
und Kantonsgrenzen (magenta) nicht zum tbrigen
Karteninhalt. Ziel dieses Anwendungsbeispiels ist es,
in den Randbereichen den Karteninhalt an die genaueren
Grenzlinien anzupassen. Lineares Verschieben oder der
Einsatz von Filter > Data Harmonization > Adeption to one Path
wirde die vorhandenen Verzweigungen (Knoten)
zerstoren.Um diese Art von Problemen rasch und
x| pragmatisch l8sen zu kénnen, wurde das

y (7 | Plugin <spezialMove.aip> entwickelt.

= Dieses wird durch zwei Werkzeuge gesteuert.

Mit dem Kreiswerkzeug wird der Wirkungsbereich radial
definiert. Der Pfeil verschiebt alle selektierten Punkte, :
abnehmend vom Startpunkt des betétigten Pfeilwerk- - s ————
zeugs. Der Startpunkt ist das Zentrum des Wirkungsbe-
reiches. Die Abnahme der Verschiebungswirkung ist linear
(andere Funktionen wéren denkbar, z.B. Gauss'sche Verteil-
ung).Der aktuelle Radius des Wirkungsbereiches kann mit
Window > KAR Dialogs > Show Messages Dialog
abgefragt werden.

=]
il g Selected “ [#)

= I Update Messages I

I23 Flugin IF-Eange for Special Mowe

MMeszages=s
ﬁﬁadius des Anwendungsbereiches: 20.EE |

Im nebenstehenden Versuch ist zu ersehen,

dass der Wirkungsbereich zu klein gewahlt wurde.
Ausserdem muss der Startpunkt der Verschiebungs-
operation nicht mit dem Zielpunkt des anzuvisieren-
den Objektes Ubereinstimmen.

Mit einer groben N&herung Radius = 50 mm,
abgetastet am Lineal und einer feineren Korrektur

mit 30 mm, erreicht man das nebenstehende Ergebnis.
Nach einiger Ubung findet man rasch den richtigen
Wirkungsbereich und die geeigneten Ansetzpunkte

fur das Verschieben. Auch bei diesem Plugin ist der
UNDO- Effekt gewahrleistet!

Die Verschiebungen werden, wenn selektiert,

auch bei den Geb&auden wirksam und zwar fur jeden
Punkt abhangig von seiner Position. In anderen
Worten: Die Gebaude sind nicht mehr rechtwinklig.
Mit Filter > Data Harmonization > Rectify closed path
konnen die Geb&aude wieder rechtwinklig
ausgerichtet werden.
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Beispiel 5:
Lokale Transformation mit gewichteten Vektoren

B5Start.ai
In diesem Beispiel wird davon ausgegangen, dass es

bei der Anpassung zweier Datenbestande aus unter-
schiedlichen Quellen und eventuell verschiedener

Massstabe, Objekte gibt, welche in beiden Datensatzen
vorkommen und referenziert werden kénnen.
In den meisten Fallen sind dies Flusseinmiindungen in ri)

grossere Flisse oder Seen. Hier sollen die blauen

Kartenelemente (1 :500000) an die schwarzen (1 :200000) ?'{q
angepasst werden. Einfachheitshalber beschranken wir K)
wir uns ausschliesslich auf das Gewasser.

Selbstverstandlich sollen mit dieser Transformation nur

die grésseren Abweichungen korrigiert werden.

Die massstabsbedingte Generalisierung muss im

Wesentlichen erhalten bleiben.

Ausgefiihrt wird diese Transformation mit dem Plugin: Krr ™~ / \

Window > KAR Dialogs > Einpassen

Snapweite: |01 kEnotenradius: |I:I.5
Einpassen: ™ Messages ™, Selected

Snapweite: IIII.1 Enotenradius: |III.5

Referenzknoten ermitteln

Referenzknoten ermitteln

Snapweite: |01 Enotenradius: |III.5

Einzupazsene Knoten ermitteln

Knoten neu aufnehrmen

Mektoren ermitieln I Laenge: Z.00

— Einpassen
[T aktionsradius: 100.0

r Knoten ausblenden, YWinkelbereich: |3|:|_|:|
|_ Garuppen als Symbole
1

Einpassen

Snapweite: |01 Enotenr adius: |I:I.5

Einzupazsen: knoten ermitteln

Wir selektieren zunachst das Referenzgewasser
vec200_gewl und ermitteln die Referenzknoten (blau),
dann selektieren wir das einzupassende Gewasser
Seen (locker) und Flusse (dicht) und ermitteln

die einzupassenden Knoten (rot).

Uberflussige Referenzknoten stéren nicht (1), soweit
sie den Knotenpaaren nicht zu nahe kommen, da nur
die am nachsten zueinander stehenden Knoten fir
die Vektorbildung herangezogen werden.
Knoten, welche einem Knotenpaar
(Vektor) zu nahe kommen (2),
mussen interaktiv geléscht werden.
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Als nachstes berechnen wir die Vektoren aus den
Koordinatenpaaren. Damit nicht aus weitauseinander-
liegenden, nicht zueinander gehdrenden Knoten
Vektoren ermittelt werden, muss eine maximale
Suchweite definiert werden (hier Lénge = 2mm).

Dies heisst jedoch auch, dass Paare die zueinander
gehoéren wiirden und weiter als dieser Schwellwert
auseinanderliegen, nicht berlick-
sichtigt werden.

Die Vektoren werden in der neu erzeug-
ten Ebene MARKIERUNG Vektor,

als Path (schwarz) abgelegt.

Vektoren ermitteln | Laenge: 20 |

Der abschliessende Schritt ist das eigentliche Einpassen.

Auch hier konnen Schwellwerte aktiv werden:

- Ein Aktionsradius schrankt fir jeden zu transformieren-
den Punkt die Anzahl wirksamer Vektoren ein.

- Wenn Knotenpaare (Vektoren) Knotenpaare
hinter einem anderen Knoten-
paar (a) liegen, kdnnen sie
ganz (¢,d) oder teilweise (b,e)
ausgeblendet werden.

- Da im Normalfall alle Punkte
einzeln transformiert werden, erfahren Symbole eine
Verzerrung. Mit dem Einschalten ‘Gruppen als Symbole;
kdnnen in einem separaten Durchgang alle selektierten Einpassen
Gruppen gesamthaft (unverzerrt) bewegt werden. L

- Inhaltsreiche, komplexe Karten kdnnen kachelweise
abgearbeitet werden. Dafiir werden im voraus
Rechtecke in der Ebene Arbeitsbereich angelegt.
Diese Ebene wird entweder interaktiv oder mit der
ersten Aktivierung dieses Plugins erzeugt

— Einpas=en
[T Aktionsradiuz: 100.0

|_ Fnioten ausblenden, Winkelberaich: |3|:|_|:| =A
I_ Gruppen als Syrnbole
1

Objekte, welche durch keine eigene oder nur sehr
entfernte Vektoren beeinflusst werden, erfahren keine
zufriedenstellende Transformation. In diesen Féllen
konnen sowohl Referenz- wie auch einzupassende Knoten
interaktiv an geeignete Positionen kopiert oder
verschoben werden. Zusammen mit den bisherigen
Knoten selektiert, werden sie neu registriert,

knoten neu aufnehnnen

die aktuellen Vektoren ermittelt

Yektoren ermitteln I Laenge: 2.0 |

und die Zieldaten neu eingepasst.

— Einpaz=en
[ aktionzradius: 1000

|_ knaten ausblandan, Winkelbareich: |3|j_|j
|_ Gruppen als Syrbale
1

Einpaszen

Weitere, individuelle Anpassungen konnen auch mit der
zirkularen Transformation (B4 S1) ausgefiihrt werden.

Es sei nochmals darauf hingewiesen, dass generalisierungs-
bedingte Abweichungen nicht unbedingt aufgehoben
werden mussen.
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Beispiel 6: Strukturraster

Strukturraster werden in der Kartografie eher vernachlassigt behandelt und enthalten oft wiederkehrende

Muster (Tapeten) und angeschnittene Symbole. Individuelle Lésungen sind in der Regel nicht moglich.

Mit Filter > Thematic Maps > Irregular Pattern ~ wurde ein Programm entwickelt, das die obigen Nachteile weitgehend
beseitigt.Von diesem Programm aus, kdnnen auch Programme fiir sehr spezifische Strukturraster abgeleitet werden,
wie Gerdllflachen, Kiesgruben, Bdschungen, etc.

Filter > Thematic Maps > Irregular Pattern

Wie im Dialog erwahnt, wird bei fehlender
Symboldefinition ein Default- Referenzsymbol mit
Mur die im Layer THM_SYMBOL _REFERENCES enthaltene Gruppen (Symbal 1 bis .
Symbol20) koennen gestreut werden, dem Namen Symbol_1 generiert.
Falls weder THM_SYWBOL_REFERENCES noch Symbolgruppen existieren, Syrnbal Definitian b
wird der Layer zusammen mit einermn Default- Symbolikreis) generiert. SY:WDDI' in 55 ;vrf
%wischen clhieserI Symbolorganisation und den lllustrator- Symbols besteht kein |SYMEIO.. vI 100 ) ® [ |- D THM SYMEOL REFEREM. ..
usarnmenhang! = =
= | - SYMBOL_L (o]
— Syrnbol Definition —; — Raster Definition —— = — .—Cj =
Syrrbol: in % ||Grundanordnung der Symbole: IOrthDgDnaI vI
|Sum|:|f 'I I 100 : _ . . . .
e Spaltenabstand: | Smm  Zeilenabstand: 2 rom Das Referenzsymbol, ein gefiillter Kreis mit dem
Cbsthae.. - . . .
[0 e Radius von 0.5 mm, wird nahe dem Nullpunkt plaziert.
I 'I ariation in 2: . . .
Rebstoe.H|f o . _ —— Mit den gegebenen Dialogeinstellungen
m haorizontal: 100 vertikal: 100 . 2 . . . o o © ©
EDLESCI e |D / und einer Fullflache (Ried) wird dieses 0 2 o %
[Laibwaic ] [ Minimaler Symbolabstand: Raster erzeugt und auf der Ebene 0o 0o "o
—— o ®
INadeIw_._ vI |D horizontal: ||:|.3 mm  vertikal: 0.3 mm THM_SYMBOL_OCCURRENCES abgelegt. © e e
Restinzs:  [1 In jedem dieser sechs Dialogfelder kann beliebig aus
o ferifeten den vorhandenen Symboldefinitionen ausgewahlt
Layer mit Fuellflaechen: |Riec| ;I werden.
IMindestabstand zurn Flaechenrand: | 0.2 mm |___ — Syrmbal Definition Raste
7 E2510 Symbal: in % || Grund:
— “ararbeitung & [ (& ETHM_SYMBOL_OCCURRENCES [o] m W
IV Sollen sich ueberdeckende 5 Bl BB THM_SYMBOL_REFERENCES O : Cnalter
ymbole entflechtet werden® Obstbaeurne Miederstarnm
B [ | I [@obstbseume Niederstamm O Obsthaeurne Hochstamm
— Hindernisse & | [» i Obstbaeurne Hochstamm lo] gibbilteﬂsecike
¥ Sollen Hindernisse beruecksichtiot werden? B [ | b [[]rebstoscke o Laubwald
Mindestabstand zu den Hindernissen: ID'3 i g F b ﬁ Gebuesch o Madelwald
[ Laubwwvald (o)
® [ | b [[\]nadebwald [6) L |
cancel | Ok I [ [ E Sumpf Cm Best in %: ID H

Symboldefinitionen (-referenzen) bestehen jeweils aus

einer Gruppe mit einem oder mehreren Path- Objekten. | ﬂ Q /\
Unterebenen und/oder Gruppenhierarchien sind innerhalb o o —
einer Symboldefinition nicht gestattet.

Fir jedes Symbol das abgebildet werden soll, muss ein Anteil in % bestimmt werden. Soll nur ein Symboltyp
wirksam sein, wird ihm ein Anteil von 100% zugeteilt. Mit dem Tabulator kann nach jeder Eingabe abgeschlossen
und auf das nachste Feld gesprungen werden. Die Differenz zu 100% wird im Feld Rest in % nach jedem Tabulator
nachgefiihrt.

Das Vorkommen der ausgewdhlten Symboltypen wird so zufallsverteilt, dass in jeder Zielflache in etwa die Anteile
stimmen. Je grosser die Flache, d.h. je mehr Symbole pro Flache, je genauer wird die vorgegebene Verteilung erreicht.
Nachdem die Referenzsymbole ausgewdhlt sind, muss noch die Anordnung des Rasters festgelegt werden:

orthogonal diagonal

v e
e o o o DI Py o . * o e ® ° o * e * o ® o .. %
® o o o ) ° * o© ° o ° ° ° ° ° °

. . o ’: o % o . o ¢ .0.0 : i . o
e o 0 0 LIDER 2 ° ® o... o © o o *, . .o oo o0
R ° . e ® e ® ° PS L P Py . °® . .

. . ° . ° ° ° ® o %o
oo 0 0 ° ° e ® o0 . . o ® oo o ® ° ®

. ° . . . . s °% s oo
® 0 0 o ° ° o o o ¢ ° ° o © o ¢ ° o 3 ° ° °

Variation x,y = 0% x=0%,y=50% x=150%,y=>50% x=100%,y=100%



Bei grosser Variation (>50%) und bei relativ grossen
Symbolen in Bezug zu den Gitterweiten, kommt es zu
Uberdeckungen. Mit der Option: Entflechten, kénnen
diese Uberdeckungen wieder aufgehoben werden.
Bertihrungen zwischen den Symbolen werden durch die
minimalen Symbolabstédnde vermieden.

o °
|
— = e
I 50 %
e | e
|
__L__
|
o ! °

| .
|
4o -
|

| e
|
1
|
e
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Symbole (griin, Strich) werden bei allen Abstands-
berechnungen nur mit ihrer rechtwinkligen Hiille
bericksichtigt. Da Bezier - Segmente ausschliesslich
als gerade Verbindungen (grln, strichliert) mit
einbezogen werden, wiirde hier die Hille auf das
schwarz strichlierte Rechteck reduziert.

Symbole mit Beziersegmente sollten daher durch
zusatzliche Punkte (rot) erganzt werden, um so eine
exaktere Hulle (schwarz, Strich), zu erhalten.

In einer Programmausfiihrung kénnen Flachen nur einer Ebene mit Symbolen gefiillt werden.
Von den selektierten Objekten werden nur die geschlossenen Paths und Compounds berlicksichtigt.
Zu den Flachenrander besteht ein eigenes Abstandskriterium.
Alle selektierten Objekte der anderen Ebenen werden als Hindernisse betrachtet und erhalten ebenfalls ein

eigenes Abstandskriterium.

Die Strichstarken der Fllflachen, wie auch die der Hindernisse, werden mitberticksichtigt.
Hier sei nochmals darauf hingewiesen, dass Bezierkurven wie geradlinige Verbindungen verarbeitet werden!

Meistens wird die Option: Entflechten = Ja benutzt.
Falls nicht, finden Uberdeckungen statt:

e
—
——

——

]

——
—
—

—
—

—

—

—

—

—

0
|

I

—
—

Entflechten = Ja

= Nein

Das Programm bedient sich zweierlei Entflechtungsmethoden: Auseinanderziehen, wenn viel Raum vorhanden ist
oder auf die Gitterpunkte zurtickbewegen, wenn eine dichte Plazierung definiert ist.

Auseinanderziehen:

—r—

—i

Minimaler Symbolabstand

Zu den Gitterpunkten:

0\

%

o Gitterpunkt

Minimaler Symbolabstand

Jede Entflechtung kann wieder zu weiteren Uberdeckungen fiihren, die dann vom Programm wieder
weiterbearbeitet werden mussen. Dicht gefiillte, grosse Flachen verursachen hohe Laufzeiten.
Eine Warnung mit einer nachfolgenden Ausfiihrung macht auf solche Grenzsituationen aufmerksam.
Wenn eine Verarbeitung aussichtslos ist, wird vorher mit einer Fehlermeldung abgebrochen.
Die in diesem Versuch gesetzten Parameter werden dann nicht gespeichert.
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In einem vereinfachten Kartenausschnitt wird versucht, verschiedene Strukturraster in Anwendung zu bringen.
In einer Tabelle werden die wichtigsten Parameter festgehalten.

<B6Start_V1.ai>

Beteiligte Ebenen:

o

[ ] THM_S¥YMECL_OCCURRENCES
7 [] THM_SYMEOL_REFERENCES

[] Obsthaeums Miederstarmm
! Obsthaeumne Hachstaram
I:I:l Rebstoecke

B
b
B
¥ Ei Gebuesch
L
B
L

IE Laubwald
E Madehwald
E Surnpf
l:‘ Rahmen
Gebaeude
l:‘ Strasse
l:‘ 'egq
l:‘ Fuszpfad
l:‘ Fluss
l:‘ FReben
l:‘ Obstgarten
l:‘ Streuobst
[ ]nrald
[ ] Ried

£ 0 10D NC IED O N O IS S D O (O | O | OO O O e

VWV VY Y (VY Y Y Y N

Referenzsymbole (zweifach vergréssert): A ol ee —

Ebene der Ref bol Grund- Spalten- | Zeilen- Variation in % Abstdnde zwischen Symbol zu Wird Fillflaiche
Fllflache ererenzsymboo anordnung | abstand | abstand | Horizontal | Vertical | Symbol | Flichenrand |Hindernis | dargestellt?

*1

Reben Rebstocke diagonal 24 mm | 2.0 mm 0 0 0mm 0mm Ja
b Obstbaume di | . *2
Obstgarten Niederstamm iagona 1.5 1.0 0 0 0 0 Nein
b Obstbaume h *3| .

Streuobst Hochstamm orthogonal| 4.0 4.0 80 80 0.2 0 0.3 Nein

Wald Gebusch diagonal 6.0 6.0 80 80 0.2 0.3 0.3 Ja
Laubwald
Nadelwald

Ried Sumpf diagonal 55 1.5 100 100 0.1 0.2 0.2 Nein

*1: Bei den Reben ist auch das Anschneiden der Symbole gebrauchlich
*2: Fur Strukturaster wie Obstgarten ware eine Ausrichtung nach der Vorzugsrichtung der Fullflache nitzlich. / (zukiinftige Version)
*3: orthogonale oder diagonale Ausrichtung mdglich
*4: Jedes Waldstiick hat seine eigene Zusammensetzung mit Symboltypen und deren Anteilen,
daher wird getrennt verarbeitet.



Beispiel 6 Seite 4

<B6_V1.ai>

Die Reihenfolge, wie die einzelnen Fillflachen abgearbeitet werden, ist beliebig.
Vor jeder Ausfiihrung missen Fillflaichen und Hindernisse selektiert sein.
Versehentlich selektierte Markierungen oder Symbole werden nicht in die Verarbeitung
miteinbezogen. Daher gentigt bei diesem Beispiel in den meisten Féllen (Wald ausgenommen)
eine Selektierung via <CtrlA>.Der Rahmen muss dabei geschlossen sein, sonst wird der Rahmen
gefillt und alle anderen Objekte werden als Hindernisse betrachtet.

Der obige Stand der Verarbeitung kann selbstverstandlich noch interakiv
verbessert werden.In zu grosse Liicken kdnnen Symbole kopiert

oder verschoben werden.

Fir die Nachbearbeitung stehen mehrere Filter-Plugins

zur Verfligung. lhre Wirkungsweise wird auf der Seite B6 S6

vorgestellt.




In einem zweiten Beispiel werden die Mdglichkeiten und Grenzen dieses Programs gezeigt.
Die roten Flachen decken um den See die Geréllflachen ab. Jede Ebene (von m12 bis g07) enthdlt Flachen
eines Strukturtyps. Hohenlinien, Textfreistellflichen und Falllinien(griin) gelten als Hindernisse.

<B6Start_V2>

AR )

. \e',-a
O

h Ty
=8
ﬂg‘\h

SR
A
Y A

~:
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f1

Gerollsymbole (x10):

- w @

f2 f3

f4 f5 fé6

Ebene der| Referenzsymbole|Grund- Spalten- | Zeilen- Variation in % Abstande (mm) zw. Symbol und | Wird Fullfliche

Fullflache Anteile in % anordnung | abstand | abstand | Horizontal | Vertical Symbol | Flachenrand |Hindernis | dargestellt?
F1,F2,F3,F4,F5 "

m12__10..] 10,20, 20, 25,25 orthogonal| 1.2mm [ 1.2mm 80 80 0.05 0.0 0.1 Nein
F1,F2,F3,F4,F5 * )

m9 10, 20' 20’ 25' 25 Orthogona| 09 09 80 80 0.05 0.0 0.1 Nein
F1,F2,F3,F4,F5 1 )

m7 10 20’ 20’ 25’ 25 orthogonal 0.7 0.7 80 80 0.05 0.0 0.1 Nein
F1,F2,F3,F4,F5 " )

m5 10,20, 20, 25,25 orthogonal| 0.5 0.5 80 80 0.05 0.0 0.1 Nein
F1,F2,F3,F4,F5,F6 i )

91 275... 5, 15’ 1 5, 20’ 20, 25 0rth0g0na| 1.2 1.2 80 80 0.05 0.0 0.1 Nein
F1,F2,F3,F4,F5,F6 * )

g9 5,15,15,20,20,25 |orthogonal( 0.9 0.9 80 80 0.05 0.0 0.1 Nein
F1,F2,F3,F4,F5,F6 " )

g7 5, 15’ 1 5’ 20’ 20’ 25 Orthogona| 0.7 0.7 80 80 0.05 0.0 0.1 Nein

*1: Wahrend der Verarbeitung wird die Strichstarke der Hohenlinien auf 0.0 gesetzt, um die Symbole
moglichst nahe an die Linien heranzubringen ohne dass sie zerschnitten werden.
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<B6_V2.ai>

Anschliessend erhalten die Hohenlinien wieder ihre urspriinglichen Strichstarken und die Falllinien werden
unsichtbar gemacht. Moglicherweise sehen die Gerdllfelder konsistenter aus, wenn man die Héhenlinien
wahrend der Geréllgenerierung nicht beriicksichtigt (nicht selektiert) und ein Anschneiden der Symbole in
Kauf nimmt. Wesentlich verbessert wiirde das obige Ergbnis durch eine professionellere Auswahl der Geroll-
symbole, der Fillflaichen und der Falllinien.

Zu Nachbesserungen stehen verschiedene Moglichkeiten zur Verfligung:
Das Werkzeug Lasso

und anschliessendes Object > Transform > Tranform Each ... :

,das Plugin Filter > Data Harmonization > Select Inside Areas

Ebene mit den Auswahlflaechen:  [Seen (mittel) Ba|

Zusarmmmengesetzte Flachen werden wie Einzelflachen behandelt!

Es werden nur die Path- Objekte selektiert, welche

rnindestens mit einern Punkt Ll innerhalb der Flaechen liegen.
komplett

mit demn Zentrum Cancel |

rmindestens mit einern Punkt

und anschliessendes Object > Transform > Tranform Each ... :



und das Plugin
Filter > Data Harmonization > Keep Selected by Name

Keep Selected by Name

Mur die Path- Objekte bleiben selektiert, welche im Mamen

I fi
Cancel |

und anschliessendes Object > Transform > Tranform Each ... :

(f4)

folgender Text beinhalten:
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f4\
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helfen zur nachtréglichen Skalierung von Geréllsymbolen.

Symbole, bestehend aus nur einem Path - Objekt kdnnen
mit

oder mit
selektiert

Select by same Geometry

Alle zum selektierten Path identischen Path- Objekte werden
selektiert. Falls diese Paths jeweils Teil einer Gruppe sind.
koennen auch die kompletten Gruppen selaktiert werden.
Die graphischen attribute werden nicht beruecksichtigt.

Filter > Data Harmonization > Keep Selectet by Name

Cancel | Ok I

und anschliessend mit Filter > Thematic Maps

I Layer THM_SYMBOL_REFERENCES enthaltene Gruppen (SYMBOL_1 bis
SYMEOL_20) koenrnen selektierte Path's ersetzen

Falls weder TH_SYMBOL_REFEREMCES noch Symbaolgruppen erxistieren,
wird der Layer zusarnmmen mit einern Default- Syrmbol(kreis) generiert.

> Place Symbols

Zwischen dieser Symbalorganisation und den lustrator- Syrnbols besteht keinen
Zusammenhang!
[

Verfueghare Symbole:
|die Zentren x|

die Zeniren
alle Punkte der Path- Objekte

|SYMBOL 3

Plazierung der Symbole auf

ersetzt werden. Die urspriinglichen Path - Objekte missen
nochmals, wie oben, selektiert und dann geldscht werden.

Filter > Data Harmonization > Select by same Geometry

Zu beachten ist, dass alle Objekte innerhalb von Ebenen,
welche mit den Namen “Markierungen...” oder
“THM_SYMBOL...” beginnen, vor einer Verarbeitung
durch Place Symbols geschuitzt sind. Deshalb ist der
Ebenennamen abzuandern, z.B.:

von “THM_SYMBOL..." zu “xTHM_SYMBOL...".

Erst mit den Optionen, welche ein richtungsabhdngiges Verandern der Symbolplazierungen flachenhaft und
entlang von Linien erlauben, ist ein wesentlicher Schritt zur semi-automatischen Geréllgenerierung getan.

Dafiir misste aus diesem Programm ein eigentliches gerollspezifisches Programm abgeleitet werden.

Ein weiterer wichtiger Baustein ware die Bereitstellung der Gerollflichen mit den Gerdélldefinitionen.

Interaktiv bis automatisch missten Hohenmodelle, Felsbeschreibungen, Geologie, etc daflir ausgewertet werden!
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Beispiel 7: Thematische Karten (THM)

Thematische Karten enthalten Abbildungen statistischer Daten in gut lesbaren grafischen Darstellungen.
Dem Thema entsprechend braucht es eine Basiskarte zur Orientierung und eine gute Erklarung der dargestellten
Inhalte in Form einer Legende.

Es wird mit dem kleinen Kartenausschnitt aus dem Beispiel 1 <B7Start.ai>, der nur die Objekte Gemeindegrenzen,
Gemeindeflachen, Seen und Flusse aufweist, gestartet. Nachdem das Basisbild bereits feststeht, sind die
statistischen Daten naher zu betrachten. Als Arbeitsplattform fiir diese Daten dient MS-Excel. Damit werden
Zusammenfassungen und Auszlige getédtigt, Formeln hinterlegt, Klassen gebildet, etc..

Der fir dieses Beispiel verwendete Datensatz ist sowohl gebietsweise wie auch inhaltlich ein Auszug aus der
Verkehrszahlung der Jahre 1970, 1980, 1990 und 2000 und beschrankt sich auf die Verkehrswege der arbeiten-
den Bevdlkerung eines Ausschnitts, der Teile von Glarus, St. Gallen und Schwyz umfasst.

Zur automatischen Erzeugung von Diagrammen sollte folgende Gliederung eingehalten werden:

In den ersten Zeilen darf ein erklarender Text (header) stehen. Danach miissen mindesten drei Datenzeilen
folgen, damit die Datenzeilen von den Headerzeilen unterschieden werden kénnen.

Die Reihenfolge X- Koordinate (Léange), Y- Koordinate(Breite) und der Spalten, die die statistischen Werte
beeinhalten, muss zwingend eingehalten werden. Der Name ist fakultativ und kann in eine beliebige Spalte
eingefugt werden. Meistens wird der Namen vor oder nach den Koordinaten positioniert. Alle Spalten sind
tabulatorgetrennt bereitzustellen.

Wir beschréanken uns auf die arbeitende Bevdlkerung der Verkehrszahlung:

i
A E C [1] E F | G | H | ¢ T &k | v [ m [ 0w [ @ [ p [ @& | m” | 85 ]
| 1 |name - Koardinate - Koordinate ohneVerkMitt Oeffverkebr | Moradfuta | Vela Maf
| 2 |Reichenburg T35 225237 329 il e Eil 210 197 n i 261 207 542 99 214 183 a0 23
| 3 |Bilten 201 2 243 7 27 ki 268 e 27 a7 b2l 2 500 124 128 162 522 E2
| 4 |Ennenda 724712 21085 T4z L 135 263 404 128 362 247 ki 180 43 332 257 204 536 282
| 5§ |Filzbach T2B4NT 220075 e 1l 3 9 167 2 52 13 w3 25 ar 16 84 H 137 ]
| B |Glans 12378 213 1778 4 55 298 L 257 882 302 1138 W 1026 i3 7z 395 1221 422
| 7 |Malis 124275 217087 i 198 262 220 460 167 437 191 383 133 30 03 30 2m 7 237
| & |Muehlehom T2 0 58 B4 kil 9 113 2% [ 1l a3 i3 103 5 83 i m 1
| 3 |Maefels 12335 21775 785 262 2 405 B2 180 B37 Ll 458 a7 T 513 333 224 823 s
| 10| Metstal TR 213775 i) 74 17 250 451 173 388 254 33 243 LG 2EE 285 217 i 196
| 1| Miederumen 12283 220862 TED 249 228 390 E24 207 433 3 480 289 543 34 32 w7 e 258
| 12| Oberumen 72302 213475 30 kL3 157 208 243 125 il 208 168 173 384 235 104 113 442 i
| 13 | Obstalden 728937 213.847 a0 23 30 12 85 2 i 4 Lil 20 il 5 ki 20 128 3
| 14 |Riedem T22487 202237 9 18 kH 58 118 13 138 55 kil 27 130 55 43 45 187 28
| 15 | Amden 128678 2234 36 30 59 15 262 43 a4 " 257 o4 20 25 134 I 320 24
| 16 | Schaenis k] 224512 09 245 135 10 LK 165 0 137 Ll 287 620 186 296 296 [:x 1
| 17 |Weesen T2 2223 a1 il e i i) a7 168 45 e a7 253 &0 134 84 kit kx)

Um Verwechslungen mit Daten anderer Herkunft zu vermeiden, nennen wir die Extension *.txt in *.thm
um und lesen dieses File via ‘place’ ein. Dabei wird lediglich eine Speicherung in einem von

lllustrator verwalteten Speicherbereich ausgefihrt. File mame: [Bxbeitendelanss thm = Place |
Es findet keine geometrische Abbildung statt. Files of ype: Tab sparated Excel et fl [, Cancel_|
Erfolgreiche Importe werden kommentarlos durchge-

fuhrt. Fehler in den Daten werden gemeldet. st

Leider zeigen sich die Illustrator Plugins wenig flexibel, e g

so sind Dialoge oder Listen unter der Funktion Erekiig o nter esseges>

place/platzieren nach dessen Ausfihrung nur ok |

umstandlich méglich.
4006 in der Mgldung Date_nfehler sagt aus, dass mit Window > KAR Dialogs > Show Message Dialog
dem 4. numerische Wert (incl. Koordinaten) i
in der 6. Zeile des Datensatzes etwas nicht stimmt. Messages o
Mehr kann man via File 6ffnen und Message erfahren.
Eigentlich sind mit dem fehlerhaften 1xxx778

zwei Fehlersituationen entstanden: |‘M Flugin [THN: Read Statistic Dat
Glarus und 1xxx778 sind zwei Namen und damit hat ST
diese Zeile einen numerischen Wert zu wenig.

= | Update Massagas |

Es= i=t ein grawvierender Fehler aufgetreten!

Diie .12 Zeile enthaelt eine wom Format

abweichende Anzahl nurnerizcher YWerte

17 anstelle von 18!
Glaruslv22 7871211 2o Tala4lscsl2




Die Diagrammabbildung wird mittels eines Filters
vorgenommen. Weil Filter urspriinglich nur fir

das Verarbeiten von selektierten Objekten gedacht
waren, muss irgend ein Objekt selektiert sein, damit
ein (erster) Zugriff auf einen Filter moglich ist.

Das selektierte Objekt bleibt unveréandert.

Zunéchst versuchen wir die Diagramme provi-
sorisch in das Basisbild einzupassen. Daflir genlgt
z.B. der einfache Diagrammtyp Sektordiagramm.
Die einzelnen Eingaben haben folgende
Reihenfolge:
- Kartenmassstab: 1 : 200000
- Naturliche Einheiten zu Bildeinheiten:
Im Excel File haben wir Kilometer und
im Dokument sind Millimeter festgelegt,
also km / mm =1 000 000
- Einpassen in das Zentrum des Dokuments:
Die Bestimmung des Abstandes zwischen dem

Nullpunkt des Dokuments und dem des Projektions-

nullpunktes ist mihsam. Einfacher sind zwei
Methoden mit Hilfe des Buttons Einpassen.

Die Diagramme werden unter der Verwendung der
Abbildungsparameter in das Zentrum des Doku-
ments plaziert. Entweder werden anhand der
erzeugten Diagramme die notwendige Verschieb-

ung ausgemessen und die Diagramme mit korrigier-

tem Abstand neu plaziert oder die Diagramme
werden gesamthaft auf die geeignete Position

verschoben und die selektierten Diagramme werden

mit File > Export... > Tab separated Excel text file (*. THM)
in ein neues Excel File zuriickgeschrieben. Nach-
dem das neue File mit place neu geladen wurde,
werden neu generierte Diagramme an die neuen
Positionen gesetzt.

- Abbildungsfaktor = Radius*'/ Quadratwurzel aus
Gesamtmenge*
In diesem Beispiel wurde 0.1 festgelegt.
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Filter > Thematic Maps > Diagrams

I Dokurment berefts festgehaltenen drgumente importieren | ader Default-Werte einstellen: Dafallt
Abbildung
{Kartenmasss(ab 1;[200000 Matuerliche Koordinaten 2u Bildkoordinaten ¢ zu rmim = 1000}, 1000000 ‘
Einpassen auf das Zentrum des Dokuments
’V Einpassen Aostand aum Nullpurk des Dolwments - [-3517.38 mm Y. [sa1zzmm ‘
A 1:
Diagrammtyp:  [Sektordiagramm =] Atbikungstador: DT Proportionalieetp LN
Strichstaerken, Kanturen
"mawma‘ [o2mm minimal 0.1 o Unterteiungstinian: [1.08 mm ‘
Rotation: [0
I Schwellwerte in Mengenwerte (oder inmm) \erfueghare Farben: [255Blue =25 =125 |
¥ Beschriftung?
Cance| oK
2 =
Massstab™* ’_

1:200 000

T T,
_ 1767 /[ \%murg Sd‘mm %
- 5000 { / — Amden g,

| e

— Niec s 0en— |

- Proportionalitat: Sektordiagramme werden flachenproportional abgebildet, daher = 2

- Strichstarken in mm

Die Dicke der Kreiskontur wird der Grisse des Sektordiagramms angepasst.
- Die Beschriftung wird fur eine bessere Orientierung eingeschaltet.
- Mit der in der Farbzuordnung definierten Farbe wird gestartet.

Alle Parameter bleiben nach einer erfolgreichen Diagrammerzeugung bis zum Schliessen des Dokuments
erhalten. Nach einem Neustart von lllustrator kbnnen mit dem Button Import die zuletzt verwendeten

Parameter aus dem Dokument zurtickgeholt werden.

Default ist eine Standardvoreinstellung.

Nach dem OK erscheint ein Dialog, der diagrammtypische Optionen beztiglich Darstellung (Generali-
sierung, Anordnung der Diagrammelemente, etc.) bereit halt.

Cancel I6scht alle Neueingaben.

* des grossten Ortes

*? verkleinert dargestellt
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Nach diesem ersten Test wird noch nach einer geigneteren Diagrammform gesucht. Wir haben vier
Zahlungen mit je vier Werten. Da bieten sich entweder unterteilte Flligel oder unterteilte Stabe an.
Unterteilte Flugel werden flachenproportional dargestellt.

Wenn wir fur den grossten Ort, Glarus, mit
ca. 3000 Arbeitenden, einen Radius von 15mm
festlegen, resultiert ein Abbildungsmassstab von
15mm / Quadratwurzel von 3000 = 0.27.

Obstalden, der Ort mit den wenigsten Arbeitenden,
wirde einen Radius = 0.27 * Quadratwurzel von 150
= 3.3 mm erhalten. Wir wahlen als Diagrammtyp
Unterteilte Flligel aus und setzen den
Abbildungsfaktor auf 0.27. Nach dem OK erscheint
ein diagrammspezifischer Dialog:

Anzahl Fluegel: 4 Anzahl Sektoren pro Fluegel d
IMax. Fluegelabstand: 15mm minirnaler Abstand. 0.5 mm

Zuordnung der Farben: — |fluegelweise x

Sthwellwerta
filer die Darstellung eines Fluegels: 0mm bezieht sich auf den Radius
fuer die Unterteilung in Sektaren 0mm bezieht sich auf den Radius

fuer die Darsteliung eines Einzelwertes 0rmm bezieht sich auf die Sektorsefne

Cancel aK

Die Flugel kénnen zueinander gréssenabhangige
Abstande erhalten.

Die Zuordnung der Farben kann fligelweise oder
diagrammweise vorgenommen werden.

de 9=
w7y

fligelweise diagramweise

Auf eine Generalisierung wird vorerst verzichtet.

Die einzelnen Diagramme (Gruppen) werden auf
geeignetere Positionen verschoben. Mit dem Direkt-
auswahlwerkzeug verschieben wir die verkleinerten
Namen und beginnen die Legende aufzubauen.
Der jetzige Stand der Karte gibt eine Ubersicht,

was mit diesem Diagrammtyp mdoglich ist.

Vielleicht sollte man die Diagramme kleiner abbilden.

Sicher sollte noch die Plazierung optimiert, sowie
die Legende vervollstandigt werden. Der Karte ist
noch ein treffender Titel anzufligen.

Neben der Darstellung des Diagrammtyps
Unterteilte Flugel bietet sich im weiteren noch der
Diagrammtyp Unterteilte Stabe fir die vorliegende
Datengrundlage an.

Die jetzigen Diagrammpositionen und die Grafik
werden gesichert mit:

File > Export... > Fluegel.thm
File > Save As > Fluegel.ai

Massstab
1:200 000

868
0

Massstab
1:200 000

Reichenburg

iy

Niederurnen

o I;Enis
ggden
Apeizhy/
g_' ghlehorr
iy N

ur|

(
"I
/




Bei einem Neubeginn werden die zuletzt gesicherten
Daten wieder geladen:

File > Open > uFluegel.ai
File > Place > uFluegel. THM

Die Ebene THM diagrams wird zusammen mit den
darin enthaltenen Objekten geldscht.
Nach einem erneuten Aufruf von

Filter > Thematic > Diagrams

erhélt man mit Importieren die friher benutz-
ten Parameter.

Stabreihen, unterteilte Stabe werden

linear dargestellt, also mit Proportionalitat = 1.

Die Stabhdhe errechnet sich aus dem

Mengenwert mal Abbildungsfaktor.

Wenn Glarus ungefdahr 30 mm hohe Stédbe erhalten soll,

betragt der Abbildungsfaktor 30 /3000 = 0.01.

Obstalden bekommt mit diesem Faktor

0.01 * 150 = 1.5mm hohe Stabe.

Im diagrammspezifischen Dialog werden

- Stabaufteilung( 4 mal 4)

- Stabbreite (2mm)

- Ausrichtung (mitte der Basis als Referenz)

- Zuordnung der Farben (stabweise)
Es kdnnte auch gruppenweise oder diagrammweise
eingefarbt werden.

Die Einteilung in Gruppen, z.B. Zusammenfassung von

zwei Zahlungen, ist hier nicht sinnvoll. Gruppen wirden

durch einen zusatzlichen Abstand gebildet werden.

Mit einer Basislinie kénnen Diagramme auch bei weg-

fallenden Staben (< erster Schwellwert) zusammen-

gehalten werden.

Die obigen Parameter zusammen mit den Plazierungs-

koordinaten der unterteilten Fluegel ergeben einen

ersten Entwurf.

Mit wenigen Manipulationen erhdlt man schon eine

wesentliche Verbesserung:

- Schriftgrosse =9

- Replazieren der Legende

- Entfernen des Legendenwertes 3000

- Ergdnzen der Legende durch Kopieren, vertikal
Skalieren und Beschriften eines Diagrammes.

- Verschieben einzelner Diagramme

- Verschieben der Diagrammnamen (Direktauswahlwerk-

zeug)

Dieser Datensatz ist sowohl fiir ortogonale (lineare),
wie auch fur polare (flaichenproportionale)
Diagrammformen anwendbar. Der Grund liegt in der
Streuung, grosste Teilmenge durch kleinste Teil-
menge (3000 / 150 = 20). Bei einer Streuung > 100
wadre eine lineare Abbildung nicht mehr sinnvoll.

Bevor die definitive kartografische Ausgestaltung
vorgenommen wird, sichert man wieder die Grafik (*.ai)
und die neuen Diagrammpositionen (*.thm).
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|
Anzahl Stasbe G Anzahl werte pro Stab E
Stabbreite 2 rmm Stababstand: 0 rmrm
Ausrichtung: Im
I Sollen Gruppen gebildet werden? Anzahl Stasbe pro Gruppe: 2
gusaetelicher Abstand 0.3 rmm
™ Basislinie?  Staerke: [0.1 mm Abstand zur den Stasben 0.4 rmm
“Wer|3engerung: W
Zuordnung der Farben: Istanweise hd
Schwellwerte:
fuer die Darstellung eines Stabes: 0 rmm bezieht sich auf die Stabhoehe
fuer die Unterteilung in Schichten 0 mm bezieht sich auf die Stabhoehe
fuer die Darstellung eines Einzelwertes: 0 rmm bezieht sich auf die Schichtdicke
Cancel I 914
2500

Massstab

Massstab
1:200 000

y mﬁ’”

"‘=FF. Mushlehom
Oh:lz an

thac

:_“w\

|
;o
]
i

Y

— Glarus

\J‘ 2500
\ 2000 | Vo, Mopesd
1500 N
1000 Ao, Motorrad
500 oeffentlichen Verkehr
155|111 ohne Verkehrsmittel
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Einfarben von Flachen fiir Choroplethenkarten

Die fiir die Farbzuordnung notwendigen Klassenwerte

werden entweder via Excel aufbereitet oder mit graf- A | B | C | D |

ischen Methoden, wie zum Schluss dieses Beispiels in 717.185181 | 23853544 Reichenburg
Kombination mit dem Dreiecksdiagramm gezeigt, 720335144 236.495433 Bilten

konstruiert. Die Daten werden wie bei der Diagramm- 724247083 Z24.008484 Ennenda
erzeugung angeordnet. 728672119 233.433602 Filzbach

T2 022156 224 653493 Glarus
724510193 230545471 Mallis

o | [ o k| —
b == RO RS s

Zur Vorbereitung l6schen wir wieder die Ebene
THM diagrams oder falls wir neu beginnen, laden wir

File > Open> B7Start_Einfaerben.ai und die Klassenwerte File > Place > Klassen.thm

Nach dem Selektieren der Gemeindeflachen starten wir
das Einfarben mit

Filter > Thematic Maps > Diagrams.

Ausser den Schaltflachen Einpassen und Import
bglm koordinatenorientierten Einfarben, sind nur noch Zuordnng via Woorgnaens]
die Auswabhlfelder Verfuegbare Farben und der -
. . Klassenreined | bis max: 200: 1
Diagrammtyp = Einfaerben von Flaechen
von Bedeutung.
Bei der Farbzuordnung via Koordinaten ist Sorge zu Cancel_ | oK

tragen, dass die Koordinatenpaare innerhalb der
einzufdrbenden Flachen liegen!

Bei der Zuordnung per Namen sind die Koordinaten Massstab
bedeutungslos. Die Namen der Flachen in der Grafik 1:200000
missen exakt mit den Namen im *.thm -File Gibereinstim-
men.

Die Farben sollten vorher bestimmt und sinnvoll
benannt werden. Falls Globale Farben oder Volltonfarben
zur Anwendung kommen, kénnen die Farbwerte leicht
gedndert werden. Bei nicht globalen Prozessfarben
missen die Anderungen objektweise vorgenommen
werden und sind daher um Vieles miihsamer.

Ueberwiegend
Zu Fuss

Oeffentlicher Verkehr
Privater Verkehr

0 ENN

Im Durchschnitt



Dreiecksdiagramme

Flr Datensatzen mit drei statistische Werten eignen
sich Dreiecksdiagramme zur Bildung von Klassen.

File > Open > B7Start.ai
File > Place > DreiWegarten.thm

In einer freien Flache wird ein beliebiges Path als

Platzhalter fur ein Filter- Aufruf selektiert bereitgehalten.

Mit dem untenstehenden Dialog wird dieses
Objekt durch ein Dreieck ersetzt.

Filter > Thematic Maps > Create Triangle

Create Triangle
IIDD |

=
Zancel |

In das selektierte Dreieck werden mit
Filter > Thematic Maps > Diagrams

die ausgewahlten Symbole abgebildet (Kreis).
Von Bedeutung sind nur die Parameter Importieren,
Einpassen und Klassenbildung im Dreieck.
Aus internen Griinden muss unbedingt die Folge
Symbole erzeugen > OK eingehalten werden.
Zusammen mit den Symbolen wird noch eine
Ebene THM triangle areas erzeugt. Der Anwender
plaziert in dieser Ebene die Zuteilungsflachen ent-
sprechend seiner thematischen Vorgaben.
Die Symbole sind in diesem Beispiel alle in der rechten
Ecke plaziert, das bedeutet, viel privater Verkehr.
Einfachheitshalber begniigen wir uns mit vier Klassen:
- Uberdurchschnittlich zu Fuss

> 25% Anteil, hellgrin
- Uberdurschnittlicher éffentlicher Verkehr

> 15%, hellblau
- Uberdurschnittlicher privater Verkehr

> 65%, hellrot
- Rest rosa

Seitenlaenge des Dreiecks in mm:

nterteilung des Creiecks: |5%

Falls die Flachen zu ungenau digitalisiert wurden,
kann dies mit Filter > Data Harmonisation > Snap Points
korrigiert werden. Es ist darauf zu achten, dass nur die
Ebenen THM triangle areas und THM triangle

selektiert sind.

Snap Poinks

Funkte verschiedener Objekte werden entweder durch ausrmitteln oder durch
‘ansnappen' an Objekte geschuetzter Layver bewegt
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v Laver mit geschuetzten Ob jektent |THM triangle

=

Die Snapdistanziradial) sollte geringer als das

0.z
kuerzeste Pathsegrnent sein. Distanz in mmm: I mm

[~ Sollen die 'gesnappten’ Punkte markiert werden?

Cancel | Ok |

A [ B [ ¢ [ D ] E [ F 1]
| T |name #- Kaoordinate Y- Koordinate zu Fuss  Oeflentlicher “erkehr Privater Yerkehr
| 2 |Reichenbury 716.95 225237 214 183 859
| 3 |Bilten 7201 223137 128 168 584
| 4 |Ennenda 724712 21065 257 204 817

AVAV >4 \A/\W\A/\

RNNLET N
.
/
\
— Erzeugen — Zuordnen — Speichern

Die erzeugten Symbole Die aus der Zuordnung

wierden den Flaechen erhaltenen Klassenwerte

<THM friangle areas:» werden gespeichert.
Symbalform zugeordnet. Diie urspruenglichen drei
m Die Reihenfolge der Ausgangswerte werden

Flaechen definiert ueberschrieben!

Jeweeils den Klassenwert.

Symbolgroesse:

ID.S mm
Cancel I
Symbole erzeugen I Symbole zuordnen Klassemnwerte SDEIEI‘IETI‘II Ok I

YA

N\
/ A\

RSN

>
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Méglicherweise sind nicht alle Zuordnungsflédchen Filter > Data Harmonisation > Close Path Objects
w!rkhch geschlqssen. Ersichtlich rmttels:
Window > KAR Dialogs > Show Inform Dialog >> Selected
Die selektierten und offenen THM triangle areas Path Objekte werden geschiossen.
. . entweder durch Ergaenzen mit einerm
werden mit nebenstehenden Plugin geschlossen. zusaetzlichen Segrrent oder
Die geschlossenen Path bleiben unverandert. durch das Ausmitteln der Endpunkte: [tusmitten ]
Mit Klassenbildung im Dreieck > Snapswaite in mm: |D 2
Symbole zuordnen > OK findet im Speicher die
Zuordnung zu Klassen statt. Aktuell sind jedoch immer cancel | ok |
noch die drei Absolutwerte.

Erst nach Klassenbildung im Dreieck >

Klassenwerte speichern > OK werden die

drei Absolutwerte je durch einen Klassenwert ersetzt. N 717 %5181 | 2385595:19|R : hc . | b
Weil die Gemeindeflachen keine Namen besitzen, 5 FED-335144 e 4‘95499 Ei,altlc Enbury
werden wir die Koordinaten fiir die Farbzuweisung 5 ?24'94?%3 22@008:18:1 EL:Ennda
benitzen. . o . 4 | 726.672119 233 433502 Filzbach
Falls ein Einpassen in die Gemeindeflachen notwendig £ | 724022156 724 B58493 Glarus
wird, erzeugt man aus den Klassenwerten Diagramme B ?24:510193 230:5454?1 Mallis
und korrigiert, wie in B7 S2 beschrieben, die Koordinaten
via Verschieben, Export und Place (*.thm).
Mazsstaby -
Eingefarbt wird wie in B7 S5 beschrieben. ey
4
VAR )
,.‘-:':_/’ /’_:.:"r-.h {_-J l" | Onerdurchschnitich
P _f.’ [T Ofentiches Verkehs
; " - = A [ Privater Verkehe
/"'. A \ [ im Durchachnier
\- 2\
Zusammen mit den Staben:
s IU.I |'_‘ et || Dubas )
. L -i--a- [ O¥tamisicher Virkehe
In diesem Beispiel wurden zuerst Diagramme erzeugt y 47\
und dann erst die Flachen eingeférbt. AN ﬁ&

In der Praxis wird eher umgekehrt verfahren.

o == D R
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Regionalisieren

Via'Place’' geladene statistische Daten werden mittels Flachen einer selektierten Ebene zusammengefasst.
Ortspositionen sollten nicht innerhalb mehrerer Flachen zu liegen kommen.

Ist dies der Fall, werden sie jeweils der letzten Flache in
der Reihenfolge zugeordnet.

Ortspositionen welche sich in keiner Regionalisierungs-
flache befinden, verbleiben unverandert. Flachen mit :
nur einem Ort verursachen ebenfalls keine Veranderung. =
Resultierende Orte werden mit den Koordinaten des
mengenmassig grossten Teilorts versehen. -
Der Kanton Glarus wird in diesem Beispiel durch die e
Koordinaten der Gemeinde Glarus vertreten.
Selbstverstandlich kdnnen auch exaktere Flachen,

z.B. Bezirksflachen, zur Regionalisierung herangezogen
werden. Die Sicherung der resultierenden Daten erfolgt
via'Export’ der selektierten Diagramme .

Die Diagramme der urspriinglichen Daten (Gemeinden)
sind nicht zwingend notwendig, wenn die Abbildungs-
parameter sicher stimmen.lhre Erzeugung hilft jedoch
Fehler zu vermeiden.

Massstab Schwvz
1200000 0 0C
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Beispiel 8: Symbole und Diagramme (THM)

Alle von THM unterstiitzten Diagrammformen kénnen vereinfacht (generalisiert) werden.
Schwellwerte steuern das Unterdriicken oder das Vereinfachen zu kleiner Diagramme.

Beim THM des lllustrator CS2 wird abgefragt, ob Positionen
mit zu kleinen Diagrammen leer bleiben oder an Stelle von
einem Diagramm ein Einheitssymbol plaziert werden soll.
Orthogonale Diagramme werden durch ein Quadrat und
polare Diagramme durch ein Kreis ersetzt.

Der Durchmesser, resp. die Kantenldnge des Ersatzsymbols
wird auf zwei drittel des wirksamen Schwellwertes fest-
gelegt. Lediglich Kreissektordiagramme erhalten ein vom
Benitzer festgelegten Kreisradiusadius.

Flugeldiagramme haben andere Vereinfachungsregeln
und erhalten keine einheitlichen Kreise.

Die Diagramme von B7 S4, halb so hoch dargestellt,
fuhren mit der unten gezeigten Vereinfachung zu den
vier Einheitsquadraten.

Schwellwerte

fuer die Darstellung eines Stabes: 2mm bezieht sich auf die Stabhoshe

fuer die Unterteilung in Schichten: 4 mm bezieht sich auf die Stabhoshe

0.5 mm bezieht sich auf die Schichidicke

v Sollen entfallende Diagramme durch ein Ersatesymbol (Quadrat) ersetzt werden?

fuar die Darstellung eines Einzelwertas:

Entweder werden diese Quadrate akzeptiert oder man

will sie durch Symbole ersetzen.

Diese in Grosse und Form identischen Konturen kénnen

in diesem Beispiel noch interaktiv selektiert werden.

Bei einer Karte mit den Gemeinden der Schweiz kommen
jedoch leicht hunderte von solchen Quadraten zusammen.
Mit dem Programm:

Filter > Data Harmonization > Select by same Geometry (B6 S7)

Select by same Geomektry

Alle zum selektierten Path identischen Path- Objekte werden
=alektiiert. Falls diese Paths jeweeils Teil einer Gruppe =ind,
koennen auch die kompletten Gruppen selektiert werden.
Die graphischen Atiribute werden nicht beruecksichiigt.

|Select same paths =1

Select complete groups
Cancel | [o]:4 I

kdonnen die Path- Objekte dieser Einheitsdiagramme (o)
automatisch selektiert und anschliessend mit

Filter > Thematic Maps > Place Symbols (B6 S7)

vordefinierte Symbole ¢ auf diese Path plaziert werden.

place Symbols

Irn Layer THM_SYMBOL_REFEREMCES enthaltene Gruppen (SYMBOL 1 bis
SYMBOL_Z0) koennen selektierte Path's ersetzen

Falls weder THM_SYMBOL_REFEREMCES noch Symbolgruppen erxistieren,
wird der Layer zusarnrmen mit einern Default- Symbolkreis) generiert

Zwischen dieser Symbolorganisation und den lliustrator- Symbols bestent keinen
Zusammenhang!

‘erfuedbare Symbole:

|5YMBOL_3 =

Plazierung der Symbole auf [die Zentren B3|

die Zentren
alle Punkte der Path- Chjekte

Achtung, unter diesen Symbolen sind die urspriinglichen
Einheitsdiagramme noch erhalten.

Sektordiagramme L

Schwellwerte:

fuer die Darstellung eines Diagramms: I 1mm bezieht sich auf den Radius

fuer die Unterteilung in Sektoren: 2 mm bezieht sich auf den Radius

fuer die Darstellung eines Einzelwertes:l n,7| bezieht zich auf die Sektorsehne

v Sollen entfallende Diagramme durch einen Einheitskreis ersetzt werden?

Radius fur den Einheitskreis | 0.5 mm

Cancel | Ok I
<B8Start>
Massstab
1:200 000
3080
2500 PO

.
||7

Refchenburg

Filzbach stz apMushlehom

— =

¥ . o
Filzbachhperadantughlehom

Die Definition der Symbole ist in B6 S1 ausfiihrlich beschrieben.



Symbole als Diagramme

Symbole kdnnen in zwei Varianten via dem Programm:
Filter > Thematic Maps > Diagrams erzeugt werden,

sowohl als klassenabhéngige Symboltypen, wie auch als
skalierte Symbole.

Die Klassenwerte werden wie in B7 S5 eingelesen.

In der Ebene THM_SYMBOL_REFERENCES bereitstehende
Symbole (B6 S1) werden in der Reihenfolge ihrer Ablage
auf die Ortspositionen abgebildet und unter THM diagrams
abgelegt (nicht unter THM_SYMBOL_OCCURRENCES,

da sie ja keine Symbole mehr sind).

Filter > Thematic Maps > Diagrams

pageamme
berafls roumene Importieren | cer Difaut-Werte ensleien. Dt
| Kartenmassstan: 1. [200 = 10000 [1000
Eangrsen ol ek Zientraem di: Dokiments —
Einpassen Abwtoned zum Mullpekel o Dokuments. % [ 351738 i ¥oo [ 94123 m
l— 1. bnaar
L K YOS > ] 1 Proportionalitaet | 4 2. o Flaeche
Sirichstasrien, Konfuren
manirnak 0.2 ien ikl |mm Uaterikgsiinken: [ 308 e
Rotation: ]u
L T B R L —
[~ Bescreiftung? S—
Cancel o [

Die nicht bendétigten Eingabefelder sind rot abgedeckt.
Ausser den Abbildungsparametern ist lediglich noch die
Beschriftung festzulegen.

Im diagrammspezifischen Dialog werden keine weiteren
Eingaben gebraucht. Die Strichstarken werden mitskaliert.

Bei skalierten Symbolen, also bei einer figirlichen
Darstellung, ist zu den oben geltenden Parameter noch

die Proportionalitdt wirksam. Es kdnnen also auch
sphérische Abbildungen, wie zum Beispiel Kugel, Wiirfel,
getatigt werden. Die Auswahl eines Symbols findet in einem
diagrammespezifischen Dialog statt. Falls keine Symbole
definiert sind, wird ein Default- Symbol generiert (B6 S1).

Skalierung von Symbolen [

Gruppen im Layer THW_SYMBOL_REFEREMCES koennen als Symbale verwendet werdan,
Falls weder THM_SYMBOL_REFEREMCES noch Symbolgruppen erxistieren,
wird der Layer zusammen mit einerm Default- Symbalikreis) generiart.

Zywischen dieser Symbolorganisation und den lllustratar- Symbols bestaht kein Zusammenhang!

Yerfuegbare Symbole: SYMBOL_1 LI
[+ Sollen Strichstarken ebenfalls skaliert weden?

Schwellwerte:

Iinimale Symbalhoehe:

2 mm
Minimale Symbolbreite; a
| cancel | [ K|

B E§ THM diagrams (o]

7 [] THM_S¥MBOL_REFEREMCES
[+ E Obsthasume Miederstamm

<B8Start_V1.ai> \

&

B o
= [ o
& [ [ Ohbstbaeume Hachstarnm (o]
B [ | b []Nedebvald 0
® [ [» ELaubwald (o]
= [ [ :Gebuesch (8]
= [ [ IRebstoecke (8]
® [| b []sumef [¢)
B[ | 1 [5]smeo ]
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Beispiel 9: Flachen aus Punktwolken

Wertneutrale Punkte, dargestellt durch Kreise oder Quadrate, . % e o o o
werden anhand ihrer Abstéande zueinander zu Flachen . . " o % °
zusammengefasst. Mit verschiedenen Distanzkriterien ol I
kdénnen verschiedene Punktdichten dargestellt werden. : . o o %o o

Filter > Thematic Maps > PointCluster ° o © R

Zusammenfassen benachbarter Punkte {Flachen} zu Flac ® 00 °

Layer filr erzeugte Flachen: |sehr dicht

Objekttyp, Punkte oder Flachen: |punktfﬁrmig (Kreise)
Maximale Distanz benachbarter Punkte [mmy]: 1.5 mm s o

Ab wieviel Punkte(>=1) zoll eine Flache gebildet werden?

I*_I'_““P_I'_

Stitzpunkidichte der resultierenden FIAchen: |mitte| o °p ° ° . ° ° ° o L e ° ° o,
Interpolation der Flachenkonturen: |mitte| 09 ol o00 ° ° ° °
Glattung der Flachenkonturen: - <B9Start>

{Kontur verlauft wischen den Stitzpunkten)

WARNUNG: Die Ausflhrung dieses Pluging kann

Minuten dauern!
Cancel |

Mit drei Ausfihrungen des Plugins erhdlt man eine Karte
mit drei Dichtestufen.

Distanz = 1.5 mm, Flachen in der Ebene <sehr dicht>
Distanz = 2.5 mm, Flachen in der Ebene <dicht>
Distanz=4 mm,Flachen in der Ebene <locker>

Die Stutzpunktdichte der resultierenden Flachen kann
gering, mittel oder hoch gewahlt werden, der Grad der
Interpolation und der Glattung auf keine, schwach,
mittel oder stark eingestellt werden.

PointCluster bentitzt neben der Distanzberechnung
nacheinander die Funktionen der Plugins:

connectPath, PointElimination und LineToBezier.

Zu kleine flaichenhafte Aussparungen wurden hier mit
select -> keepPathSelectedbyGeometry(box size=1.5mm) > delete

eliminiert. Zusammengesetzte Pfade (compounds)
mussen vom Anwender selbst erstellt werden.
Selbstverstandlich konnen die Flachen im nachhinein
zusatzlich gefiltert, verschieden interpoliert und geglattet
werden.

Stitzpunktdichte: gering hoch mittel mittel gering gering
Interpolation: keine keine schwach mittel stark stark
Glattung: keine keine schwach mittel keine stark
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Siedlungsflachen

Gleich wie bei den vorherigen Punktwolken, wird hier die Nachbarschaft der Gebdude untersucht.In diesem

Beispiel wird angenommen, dass fiir eine Siedlungsflache mindesten zehn Gebadude notwendig sind.

Die Siedlungsflachen koennen nach drei verschiedenen Methoden ermittelt werden:

- punktformig, die Gebaude erhalten einen Zentrumspunkt.
Die Ausdehnungen der Gebadude werden nicht beachtet.

Zusammenfassen benachbarter Punkte (Flachen) zu Fl3

<B9Start_V2

Layer fiir erzeugte Flachean: ISiedIungsgebiete ;|
Cbjekttyp, Punkte oder Flachen: |punktfﬁrmig (Kreisa) ;l
IMaximale Distanz benachbarter Punkte [mm]: 2 mm

Ab wieviel Punkte(>=1) soll eine Flache gebildet werden? [0
Stiitzpunktdichte der resultierenden Flachen: |mitte| ;[
Interpolation der Fldchenkonturen: |mittel |
Glattung der Flachenkanturen: -

{Kontur ver|auft zwischen den Stitzpunkten)

WARNUNG: Die Ausfihrung dieses Plugins kann

Iinuten davern!
Cance| |

- Umrisse (bounding boxes) der Gebdude werden gepriift.

Objekttyp. Punkte oder FIAchen: Flachen, Urnrisse (Gebaude, etc) ;[

IMaximale Distanz benachbarter Punkte [mm]: I 1.8 mm

Da hier die Ausdehnung der einzelnen Gebaude beriick-
sichtigt wird, muss die Prufdistanz verkleinert werden,
von 3 auf 1.8 mm, damit ein vergleichbares Ergebnis er-
zielt wird.

- Die exakten Flachen der Gebaude werden berlcksichtigt.

Cbjekttyp, Punkte oder Flachen: |Fléchen, exakt (Gebaude, etc) Ll
Maxirnale Distanz benachbarter Punkte [rmn]: Im
A wievial Punkter>=17 soll eine Fliche gebildet werden? [0
Stiitzpunktdichte der resultierenden Flachen: |Gering Ll

Mit den Parameter Stiitzpunktdichte, Interpolation und Glattung kann die geeignete Flachenstruktur eingestellt
werden. Die Aussparungen in diesem Beispiel sind wahrscheinlich zu vernachlassigen.
Die Laufzeiten betrugen 3,8 und10 Sekunden.
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Gebadude rektifizieren und an Referenzgeraden angleichen

Alle Segmente eins Gebaudes werden gepruft inwieweit ihre Winkel modulo 90 voneinander abweichen.
Segmente deren Winkel innerhalb +- Abweichung (15 Grad) liegen, werden auf einen Mittelwert gesetzt.

Die Schnittpunkte (Gebaudeecken) werden neu berechnet..

Filter > Datea Harmonization > Rectify closed path

Geschlossene Path- Objkte rechtwinklig ausrichke

Maxirnal bericksichtiote Abweichung in &ltgrad: I 15
[~ Orientieren der rektifizierten Gebaude nach einer Referenzgerade

™| Fositiomieren eur Referenzgerade mit denn Abstand: I 0 mm

Die Referenzgerade besteht entweder aus einern selektierten Teil-
stuck eines offenen Pathobjekts oder aus einern 2wei Punkie- Path.
Die Gebaude durfen durch die Referenzgerade nicht geschnitten

wietden!
Cancel | (054 I

Die rektifizierten Objekte kdnnen auf eine Referenzgerade
orientiert und mit einem konstanten Abstand ausgerichtet
werden. Dies kann nacheinander oder bei einfachen
Situationen mit nur einer Ausfiihrung des Plugins vorge-
nommen werden.

<B10Start_V2.ai> enthalt funf Referenzgeraden und muss
daher in mindestens sechs Schritten bearbeitet werden.
Zuerst werden alle Gebaude rektifiziert, damit auch die,
welche keinen Bezug auf eine Referenzgerade haben,
rechtwinklig werden. Dann werden Referenzgerade fir
Referenzgerade die geeigneten Gebdude verarbeitet. Fur
das Selektieren eignet sich am besten das Lasso- Werkzeug.
Der Schwellwert Abweichung und der Abstand zur jeweil-
igen Referenzgerade muss von Fall zu Fall angepasst
werden.

<B9Start_V3.ai>

* Davorerst die gleichzeitige Ausrichtung
auf zwei Referenzgeraden noch nicht

méglich ist, miissen solche Gebdude
interaktiv bearbeitet werden.
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Gebadude zu Rechtecke, Eckgebaude oder Reihen zusammenfassen

Alle Segmente der selektierten Gebaude werden gepruift inwieweit ihre Winkel modulo 90 Grad voneinander
abweichen.Die liberwiegende Ausrichtung (Vorzugsrichtung) wird auf das oder die resultierenden Objekte Uber-
tragen. Es findet keine Ausmittelung aller vorkommenden Winkel statt.

Filter > Data Harmonization > Generalize Buildings
genetalisiert Gebiude

Layer fir generalisierte Gebaude: |genera|isierte Gebaude j

Art der Generalisierung: -
Anzahl GebAude pro Reine: ID— =0: gleichbleibend
Anpassungsfaktor (0.5 bis 2.00: Il—

AufIfsUng: fhoch x|

Cancel |

At der Generalisierung: Rechteck

At der @eneralisierung:

Art der Generalisierung: -

Anzahl Gebaude pro Reine: | i) =00: gleichbleibend
&rt der Generalisierung: |Reihe LI
Anzahl Gebaude pro Reihe: I 3 =0: gleichbleibend

. . . m
Die Quadrate werden zundchst in

flachengleiche Rechtecke umgerechnet.
Mit dem Standardwerkzeug Verschieben o
konnen einfach geeignete Rechtecke
oder Quadrate erreicht werden.

j

Der Anpassungsfaktor entspricht einer Skalierung und
wird je nach Generalisierung gesetzt.

Werden viele Gebaude zusammengefasst genligt
meistens eine kleine Auflésung zur Berechnung.

Eine hohe oder mittlere Auflosung kann bei der
Zusammenfassung weniger Gebaude erforderlich sein.
Eine hohe Auflosung, d. h. ein feinmaschiges Hilfsgitter,
verursacht eine langere Ausfiihrungszeit.

Mit dem Lasso wird Gebdudegruppe fiir Gebaudegruppe
selektiert und dann verarbeitet.

<B9Start_V4.ai>

\

~
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l',

- Anpassungsfaktor = 1.4
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Beispiel 10: Angleichen von Symbolen an offene Path

Symbole (z.B.Bahnstationen) werden an offene Paths (Bahnen) tangential angeglichen. Die urspriinglichen
Positionen werden von geschlossenen Path- Objekten (Kreise, Vierecke) stellvertreten. Diese wurden digitalisiert
oder via Place (.thm) eingelesen und dann als (Diagramm-) Symbole erzeugt. Sofern diese Stellvertreter nicht exakt
auf den Path- Objekten liegen werden die Positionen warend der Angleichung innerhalb einer Snapweite korrigiert.

Filter > Thematic Maps > Adjust Symbols <B10Start>

)

Tangentiales Ausrichten von Symbolen auf Path- Objekte

Zwischen der hier verwendeten Syrmbolorganisation und den Illustrator- Syrmbalen

besteht kein Zusarmrnenhang!

TH- Syrnbole werden in der Ebene <THM_SYMABOL_REFEREMCES » als Gruppen

bereitgehalten.

Yerfiighare Symbale: [SvraBoL_1 | b

IMaxirnale Distanz zurn nachsten Path (Bahnliniz) [rmn]? I 0.5 mm

Taleranz zu Bezier- Kurven [mm]7? I

Cancel |

Wenn keine Symbole definiert sind oder der Ordner

<THM_Symbol_References> nicht existiert, wird dieser
Ordner vom Plugin angelegt und ein Default- Symbol
<Symbol_1> erzeugt .

Die Plazierung auf Bezier- Kurven wird nicht exakt berech- ’
net, sondern linear angenahert. Der Grad der Anndherung

wird mit der Toleranz zu Bezier- Kurven vorgegeben.

Auf Verzweigungen, resp. Kreuzungen werden die Symbole

E ) -

mit dem Orientierungswinkel null Grad selektiert gesetzt.
Sie konnen anschliessend interaktiv spezifisch orientiert
werden. Mit einer Zuordnung in die Ebenen Haupt-

und Nebenbahnen und einer ebenenweise Verarbeitung,
kann dieses Problem eleganter gelost werden.
Ausserhalb der Snapweite liegende Stellvertreter bleiben
fur eine Nachbearbeitung selektiert und werden durch
keine Symbole ersetzt.
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